Cannot spy/record Mobile

Hello experts,

I got the error when trying to spy/record Mobile application. On Katalon UI I got an error popup ‘Fail to start the Appium server in 60 seconds’

I open appium.txt file in project folder and see the following log

[35m[Appium][39m Welcome to Appium v1.8.1
[35m[Appium][39m Non-default server args:
[35m[Appium][39m   port: 49998
[35m[Appium][39m   chromeDriverPort: 49999
[35m[Appium][39m   tmpDir: C:\Users\ADMIN\AppData\Local\Temp\\Katalon\Appium\Temp1542704635422
[35m[Appium][39m Appium REST http interface listener started on 0.0.0.0:49998

I recognize invalid path on the log C:\Users\ADMIN\AppData\Local*Temp\\Katalon*\Appium\Temp1542704635422

Is it the reason that I cannot spy/record mobile application or another reason, please help to advice.

Thank you

Hi Tam,

I wanted to make sure that you saw the instructions on the Troubleshooting page for the 60 second error:

Set your Appium Log Level to “Debug” which you can find this option in Windows > Katalon Studio Preferences > Katalon > Mobile to generate debug logs of Appium.
After this change is applied, retry your record/spy session and then open generated .appium file in the project folder.
Somewhere in this file you are likely will see these lines:
[debug] [ADB] Running '..\adb.exe' with args: [...] ``[debug] [ADB] Found package: 'com.abc.def.xyz' and fully qualified activity name : 'com.egh.jik' ``[debug] [ADB] Incorrect package and activity. Retrying.
The root cause is Katalon Studio can’t start application due to incorrect package and activity by default, so you need to add additional settings to desired capabilities:

  • Navigate to Mobile settings (Project > Settings > Execution > Default > Mobile > Android)
  • Add the following key
    Name: appWaitActivity
    Value: com.* (based on the prefix of ‘Found package’ log)

Based on your log above, it seems like you might have done the logging part, but I was wondering if you set the appWaitActivity setting (you can try just com.* or the bundle identifier for your app).

Hope this helps,

Chris

Hello, sorry for the late reply, I did same steps on another machine and it worked fine. Then I reset the OS, and it worked on my machine too.

1 Like

Hi Chris,

I have navigate to Project -> Settings -> Execution -> Default -> Mobile -> Android, but I can not find appWaitActivity, could you tell me more detail?

Frain,

Cheers

Hi @hountari,

The section you want is Project->Settings->Desired Capabilities->Mobile->Android.

Then you can Add a new property and fill in the values:

Hope this helps,

Chris