Unable to record/Spy few mobile apps?

I’m not able to record or spy few mobile apps (eg:Amazon ), it will launch the app for few seconds and close but it will not load the screen?

Thanks in advance.


It worked:-)

Thank you.

Please find the new log file.


Is your newest .appium logs has been configured using ‘Debug’ level as I’ve stated from the beginning?

Even for same app Rec/Spy is not working.It worked only for the first time.When i tried to record again it will launch the app and close immediately.

And also not able to launch directly from script.

That settings is only applied for that specific application only. When you record or spy on another application, it will not work. Is it the same application when you run or record/spy?

Below is the console error,when i try to run app directly.


Sorry,it worked only for the first time.After that none of the app is getting recorded/spy.

Please find the below log file.


Please try the following steps:

  1. Navigate to Mobile settings: Project -> Settings -> Execution -> Default -> Mobile -> Android

  2. . Add ‘appWaitActivity’ key and value: ‘com.mint.core.overview.PhoneOverviewActivity’

After above configurations, please try to record/spy again.

Please set your Appium Log Level to “Debug” (You can find this option in Windows > Katalon Studio Preferences > Katalon > Mobile), then retry Mobile Object Spy and send me the appium.log file again for further investigation which located in your project folder (https://i.imgur.com/IyxzrCI.png).

it worked Unable to record/Spy few mobile Appium app

Omg based on that logs, looks like the previous settings value you’ve set has been changed from within the application, so in order for Katalon Studio to works now, you need to change ‘appWaitActivity’ key to ‘*****’ value to prevent other changes from application later.

Here is the log from your first one:

Found package: 'com.quicken.qm2014' and fully qualified activity name : 'com.mint.core.overview.PhoneOverviewActivity'

Your newest one:

Found package: 'com.quicken.qm2014' and fully qualified activity name : 'com.mint.core.overview.PhoneOverviewActivity'

Cool.It’s working now.

Thank you.

Please find the log file.

I’m able to launch other apps successfully and record it ,facing issues with only few apps.


Yes, it worked for me also but the appium app is unable to Spy & record during the process.

Unable to capture objects in android emulator but same is working fine in real device

I want to automate a hybrid mobile App built in
Cordova using emulators. I am not able to capture elements on an
emulator. While capturing the elements, the element retrieved is not
found when the script is executed. Along, the elements on a HTML panel
object are never captured. I made the script on the real device with
same specification as my emulator and it worked like a charm there. But
the emulator always behaves unexpected.

Any help will be highly appreciated. I am really stuck in this issue.


I got an issue for start my mobile testing in katalon. I’m new with it hoping for your help with this.

thank you.