Cannot send the test request. Reason: java.lang.NullPointerException

(Stack trace: java.lang.NullPointerException

at com.kms.katalon.core.testobject.internal.impl.HttpBodyContentReader.fromSource(HttpBodyContentReader.java:33)

at com.kms.katalon.core.testobject.ObjectRepository.findRequestObject(ObjectRepository.java:282)

at com.kms.katalon.core.testobject.ObjectRepository.readTestObjectFile(ObjectRepository.java:167)

at com.kms.katalon.core.testobject.ObjectRepository.readTestObjectFile(ObjectRepository.java:154)

at com.kms.katalon.controller.WebServiceController.getRequestObject(WebServiceController.java:30)

at com.kms.katalon.controller.WebServiceController.sendRequest(WebServiceController.java:36)

at com.kms.katalon.composer.webservice.parts.RestServicePart$2$1.run(RestServicePart.java:132)

at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

)

image.png

I didn`t understand what`s going on but problem resolves when I re-add url and after that restart Katalon Studio

So another question or suggestion. When resize console
its cover Response window.

Maybe scroll can fix it problem ?

mb_scroll.png

Console_cover.png

Hi xio,

Thanks for your information. However I’m confused about what you are trying to say so it, can you provide some reproducible steps?

Vinh Nguyen said:

Hi xio,

Thanks for your information. However I’m confused about what you are trying to say so it, can you provide some reproducible steps?

Hi Vinh Nguyen,

Sure ! With pleasure. So when i start my project in Katalon Studio 5.3.1 as usual then I saw update message and download KS 5.4. After with new Katalon Studio 5.4 I opened my project with File -> Open Project menu and when project was loaded I tried to start my RESTful tests and saw java.NullPointerException in every test and was really disapointed about it.

And when I decided to check the objects of the repository, I was pleasantly surprised to see the new interface, for which you guys have a special thank you. After finding the query that I wanted, I checked all the settings and tried to test the request and got the same error that I posted above

I think it’s the same problem as i mentioned here http://forum.katalon.com/discussion/6158/http-body-of-ws-rest-requests-are-missed-when-you-migrate-from-5-3-1-to-5-4#latest just check your bodies/headers-they are probably empty. But I’ve discovered that properties migrates Ok.

Спасибо Вань ! Я уже разобрался. Во втором посте решение проблемы.

Thank you Ivan ! I already resolve problem. Answer is in the second post

You are rigth it same problems

  1. http://forum.katalon.com/discussion/6158/http-body-of-ws-rest-requests-are-missed-when-you-migrate-from-5-3-1-to-5-4#latest
    2 ) http://forum.katalon.com/discussion/6139/always-get-error-java-lang-nullpointerexception-when-place-webservice-test-object-to-variable#latest
1 Like

Same problem with the “Unable to send request (Root cause: java.lang.NullPointerException)” but this time it in one line of code: “def respRecStart = WSBuiltInKeywords.sendRequest(reqRecStart)” I’m going insane cuz hole code is a “CopyPaste” from another TestCase and there it works perfectly (after resolving stupid problems from my post 6158 & post 6139). Developers of KS, please let it work somehow… :confused:

UPD: no such problems on 5.3.1(I wasted whole working day struggling with 5.4 & thought that I’m a fool :expressionless: ) - so wake me up when 5.4 will get update with all fixes! B)

I’m sorry, dear KS DEV guys - the problem, described above by me - just a problem of my own inattention…

1 Like

NullPointerException is a RuntimeException . Runtime exceptions are critical and cannot be caught at compile time. They crash the program at run time if they are not handled properly. When a class is instantiated, its object is stored in computer memory. The NullPointerExceptions occur when you try to use a reference that points to no location in memory (null) as though it were referencing an object. These include:

  • Calling the instance method of a null object.
  • Accessing or modifying the field of a null object.
  • Throwing null as if it were a Throwable value.

I am facing the same problem, after analyzing the error log. I think it is not connecting to http://update.katalon.com/.

I am not sure what might be the cause, but I got the above findings.

  1. I tried the rest test URL on Postman and it works fine.
  2. Installed the latest version, but facing the same issue.
  3. Re-added URL and Restart the Katalon, but it is still there.

Thanks,
Pradyumna Varadpande

@pradyumna.varadpande, would you mind sending us your request file (.rs) file? That will help much in investigating the issue