Cannot generate test steps when using spy web

  • Katalon Studio Version: 7.8.2
  • OS Version: 11.1
  • Browser Version: Chrome 87.0.4280.88, Firefox 84.0.1

Steps to Reproduce:

  1. click on Spy Web on the main toolbar

Expected behavior: the Object Spy window is displayed

Screenshots:




Katalon_error.log (124.0 KB)

I installed Katalon a day ago and was using it happily (I have previous exp), I used spy web and created feature files and groovy scripts. Then I created a test script and I was able to use Spy Web for the first time and was successful. Unfortunately when I tried it again, the second screenshot displayed ‘Do you want to continue recording test case…’ I selected ‘Yes’ (the other option also failed to work) and the first screenshot displayed ‘Cannot generate test steps’ . Subsequently every time I click to use Spy Web, I got the same ‘Cannot generate test steps’ message.
I have tried deleting the content in the Home/Katalon Studio folder (also deleting the whole Katalon Studio folder before I re-install Katalon again) but the problem persists.
I noticed most people have similar problem with Record Web, so I tried it also, I don’t normally use it but I am pretty sure after moving around the test site from page to page I should not get the blank Object Spy screen in the third screenshot??
Attached error log, please investigate.

1 Like

Hi @blancheho,

This is an issue of Katalon Studio on macOS Big Sur. We will fix this in v7.9 but the workaround here is downgrading to macOS Catalina for better Katalon Studio experiences.

1 Like

Glad to know that it’s a known bug. Thank you for your help

1 Like

I’m having the same issue on Big Sur. Please fix it fast :slight_smile:

Hi @blancheho, @b.rentrug

Please try out v7.9.0.rc beta release. The official release will come at the end of January.

Thanks

I’m still experiencing this issue on v7.9.0. I have a Test Case A and Test Case B. I copied the code from Test Case A to Test Case B. The issue started happening after this when I try to launch Record Web. I deleted Test Case B, but I still receive the error when attempting to Record Web from Test Case A. I need to close Katalon and reopen for this error to go away. I’m able to Record Web from other test cases, but as soon as I open Test Case A, I receive the error on that test case and all other test cases.