Cannot enter text in text field


I am creating a form which has Text Field, i recorded steps using Record web function, but when i re-run the script it does not enter the text in text field.

Is there any resolution for this?

Here is the error i get

Unable to set text ‘Test Form 555’ of object ‘Object Repository/Create Form/Page_Project Forms/input__0_2_0_2_myORI_FORMTITLE’ (Root cause: com.kms.katalon.core.webui.exception.WebElementNotFoundException: Web element with id: ‘Object Repository/Create Form/Page_Project Forms/iframe_createFormIframe’ located by ‘By.xpath: //iframe[@src = ‘$$cs5rrL_10105104$$gZ1QZr_’ and @id = ‘createFormIframe’ and @name = ‘createFormIframe’]’ not found)

Try waiting for the text field to appear by using

_Wait Until Element Visible(Object)
before interacting with it.

Also, if your object is inside of an iframe, use

WebUI.switchToFrame(findTestObject('Object Repository/Create Form/Page_Project Forms/iframe_createFormIframe'), 5)


1 Like

I am having this same issue with entering a numerical value. It works without fail on an old Selenium version. I’ve tried various approaches, including waiting for the text field. Are there any other workarounds or is this a bug being worked on? Any help is appreciated. Thanks!

If the key ‘set text’ is not working, try to use the key ‘send keys’ to set text in the form!