Build failed: license quota exceeded, Whitelabel Error Page

I just tried to kick off my Jenkins build and ran into this error. This is a new one for me. I have a valid runtime engine license and no other executions were happening. I only have 1 build executor enabled in Jenkins. I checked TestOps and there aren’t any in there hanging either.

Here is the relevant console output:

00:00:08.315 Activating...
00:00:08.330 Start activating offline...
00:00:08.336 Finding valid offline licenses in folder: C:\WINDOWS\system32\config\systemprofile\.katalon\license
00:00:08.345 The number of valid offline licenses: 0
00:00:08.351 Offline activation failed.
00:00:08.351 Start activating online...
00:00:11.723 TestOps: Unexpected response code from Katalon TestOps server when sending request to URL: https://analytics.katalon.com/api/v1/license-keys/activate?machineKey=xxxxxxxxxxxxxxxxxxxxxxxxxx&ksVersion=7.0.4&email&sessionId=36170653-5cd2-43a0-8c1b-a7519e03889a&hostname=T450S-W10-JPalmer&package=ENGINE. Actual: 400, Expected: 200
00:00:11.744 License quota exceeded.
00:00:11.744 Online activation for console mode failed.
00:00:11.744 Activation failed. Please make sure you are using a valid license.
00:00:11.746 All launchers terminated
00:00:12.489 
00:00:12.489 C:\Users\jpalmer\Desktop\Katalon_Studio_Windows_64-6.1.3\Katalon_Studio_Windows_64-6.1.3>exit 3 
00:00:12.492 Build step 'Execute Windows batch command' marked build as failure
00:00:12.756 Finished: FAILURE

And here is what the link says:
Whitelabel Error Page

This application has no explicit mapping for /error, so you are seeing this as a fallback.  Thu Dec 05 04:02:17 UTC 2019 There was an unexpected error (type=Unauthorized, status=401). Full authentication is required to access this resource


17 minutes ago is when the first failure happened and no builds that I’ve tried to start since have worked either. Does this mean I have to wait 43 minutes from the first failure?

1 Like

Update: This is happening again this morning. When I got in, there was a build stuck in progress that had started last night (but I had turned my machine off in the meantime-- this runs locally).

I aborted the build, waited a few minutes, and tried to start another but I’m getting the same error as above and the same scenario on the licenses page.

Callout to @devalex88 @duyluong @ThanhTo @Thong (re Katalon Licensing/TestOps)

1 Like

Another update: I just retried the build and now it’s running. Here’s what my license page says now. 20 minutes ago, it said it expired in an hour, so it appears to have been reset.

Up until yesterday, I’ve had no problem at all aborting builds and then immediately restarting it, so I’m not sure what’s happening. I need to be able to continue to do that so if there’s a problem with my license or the process I’d like to address it.

2 Likes

Agreed.

There is no doubt that the tech-change introduced by the v7-era has introduced a number of moving parts that were not there in prior versions. I know that @devalex88 et al are working on this stuff diligently but the fact remains, we’re not quite there yet.

Hopefully, someone will jump on here to explain the issue you’re seeing - this one needs to be documented, top to bottom.

2 Likes

Hi @jpalmer,

For online license, when you abort your build, Katalon TestOps will consider a license as “inactive” after 10 minutes. Please wait for 10 minutes and retry your build.

In case you want to terminate a session immediately, you can deactivate the machine in Registered Machines.

Is that a new behavior @anhqle? I’ve been using the RE license for 2+ weeks and have never, until this week, run into this. And that is with me aborting and immediately restarting builds within seconds several times a day every day.

Is there any negative to deactivating the machine? Right now, I run everything locally via Jenkins, so I don’t want to delete my machine ID and then have issues running from it again.

Thank you!

1 Like

Deactivating a machine will only terminate sessions on that machine. So just make sure you deactivate the correct machine ID, then everything should be okay.

2 Likes

Good to know, thank you!

So I guess the only question that remains is what changed? Why was I able to start and stop builds at will in a matter of seconds until Wednesday?

2 Likes

This issue is occurring for us as well; we are unable to start/stop builds at will in a timely manner with a valid KRE.