Bdd is not executing for mobile automation

when i tried to execute the code. it always give this message “Verification accomplished successfully” but it is not executing the code". can someone tell me what’s wrong with the code? here i have added feature file and step definition code
My Feature file
Feature:Login feature
Scenario outline:Test login with valid credentials
Given I want to navigate to Landing Page
When User Click on login tab
And I enter “” and “”
Examples :
| username | password |
| | Tester@123 |

Step Defination
class LandingPage {
* The step definitions below match with Katalon sample Gherkin steps
@Given(“I want to navigate to Landing Page”)
def navigateToLandingpage(){
println(“\n I want to navigate to Landing Page”)
Mobile.startApplication(‘C:\Users\anusha.kaja\Downloads\Aauti_Events_03_10_2023.apk’, true)
@When(“User Click on login tab”)
def clickLogin(){
println(“\n User Click on login tab”)
Mobile.tap(findTestObject(‘Object Repository/android.view.ViewGroup’), 0)
@And(“User enters (.) and (.)”)
def enterCredentials(String username, String password){
println(“\n Iam Inside enter Credentials”)
println(“username :” + username)
println(“password :” + password)
Mobile.setText(findTestObject(‘Object Repository/android.widget.EditText (2)’), ‘username’)
Mobile.setText(findTestObject(‘Object Repository/android.widget.EditText (3)’), ‘password’)

1 Like

@anusha.kaja Is it not doing any of the execution or just certain steps? One thing I noticed is that in the And statement you have “” for the instead of:

And I enter <username> and <password>

Are there any other logs you get from the console about the steps it is verifying?

Yeah, I have the same problem, Is anyone on Katalon’s side help??? Does Katalon Studio support BDD testing on mobile???

@ethan.pham I am on a slightly older version of Katalon Studio (8.6.8) but have setup BDD on mobile for both iOS and Android. I am not sure if there is a bug in newer versions that allow this to no longer execute correctly.

@kreno Can you locate document that you used to configure your BDD setup that @ethan.pham can read to see where he can fix his issue?

One other thought I had is we still have the same appium version limitations. Katalon Studio still only supports appium 2.0 in the proof of concept version or by using remote execution. You will need to either user appium version 1.22.3 or below or use one of these workarounds to get appium 2.0 to work.

Here are the docs I used for setting up the BDD projects:

1 Like

I think the problem is come from Katalon tool. At first I create a normal mobile project then add some normal test cases, then I decided to convert all of them to BDD (add steps on feature file, glue, steps definition, …) and run it, so the problem is it can find my feature file but inform there is no test step, and it throws a message like @anusha.kaja mention! After that, I tried to create a Web UI BDD project and add all the steps of previous mobile project. Vãi, not sure how but successful to run BDD mobile by this way. Anyway, many thanks @grylion54 @kreno for support!!!