AssertionFailedException when loading Project


#1

For some unknown reason, when I try to load my Project (which previously loaded and executed fine), I now get a popup indicating it will not load due to an AssertionFailedException. If I try to create a brand new project, I get the same error when it is trying to load in the project (it created it, I can see it in the directory structure). No additional details are provided.

I am able to use the same Katalon Studio version (5.10.1) and the same project as a different user on my system and it still works. Any suggestions (I already tried to go back to a previous version of Katalon Studio and I get the same error)


#2

It sounds like this might be a permissions problem with that particular user on your system.

Whenever I have problems loading a project, this seems to help:

This won’t do anything for your permissions obviously, but it will remove all of the binaries from your project and let the studio attempt to rebuild them.


#3

I removed the files/directories it suggest and upon loading the project I got an three errors which said: “Auto-ignore derived resources”, followed by an error Building Workspace error which said "Errors running builder ‘Java Builder’ on project … assertion failed.

The project did load, and I can view but not update anything. When I try I to save an update I again get an assertion failed error. I exited out and now have the same error I started with. An assertion failed error and the project won’t load. None of my permissions have changed - that I am aware of.

I appreciate your help