Android Device Not Found


Katalon can’t find the Android device listed on my computer. The Android firmware is 7.0 and I’ve tried using Katalon 7.0.4 and 6.1.0.

A few days ago I tried and the phone was found. Katalon tried to install the SDK but failed because I didn’t have Node.js installed yet. I don’t have admin privileges so I had to wait for it to be installed.

Now I have Node.js 11.12.0 installed but Katalon can’t find my device anymore.

I’ve followed these steps:

Developer options are on and I’ve pressed “Allow” on the phone notifications. I asked for the command line step to be checked and my device isn’t listed in the adb devices.

There aren’t any steps about this in the troubleshooting page. Other sites say to make sure the Android SDK is installed, but I can’t get Katalon to install the sdk because it can’t find the device!

What should I do?

1 Like

I faced same issue.Katalon can’t find the Android device listed on my computer. I installed Memu android emulator. Yesterday, it was worked. Today I can’t worked. Strange issue