After test suite completes running, the send email feature does not works

I have configured the send email report feature correctly, tested by sending test mail and used to get emails reports after test suite execution before but since a week or so, may be due to some reasons I don’t get the report mail

After test suite completes i can see in the test suite progress that send email feature is running but it keeps loading without an end.

Check attachment

Hello Mukkund ,

You have to check that you’re doing the right steps.
You must first set Project> Setting> E mail.
For example, try sending a test email as shown below.

Then, you must add the mail address you want to send mail to Mail recipients on the test suite.
Please look at the screenshot.

see you.


I have already configured as you mentioned, used to get email reports earlier, and for another project, I get the email reports for the test suites it is just for this project where in I have 4 test cases in a test suite that I don’t get the mail.

It is annoying now


I checked and found out that if the test cases in suite pass then report is sent successfully otherwise, even if a step fails the send email doesn’t executes. I keep seeing the " sending email " in test suite progress. Any idea?

Hello Mukund ,

please , you can look bellow link.

Please make sure you perform all checks. And use it as an default email template.

Got the solution for this issue. @duyluonganh helped me out. The katalon.log file showed out of memory error. so I had to modify this property from: -Xmx2048m to -Xmx4096m in katalon.ini file. Hope this helps others as well.

@ThanhTo I am also experiencing the same issue. I am not getting report email after test suite run. I used to get emails before. Last email I got in Oct 22, 2019. I have increased the memory size as well as @Bal_Mukund recommended but still no luck. Iam receiving the reports in reports folder but no email is triggered anymore. Below is my configuration

I used to get emails before. The last email got on Oct 22, 2019

Please help

I solved the issue by setting up Yahoo mail