Why am I getting 'Failed to activate with TestCloud license' if I have one?

I am trying to run my test case suite from Azure DevOps pipelines using Katalon Runtime Engine along with Katalon TestCloud to test my web app with different OS and browsers configurations.
For my yaml file I used the following response to set it up → here

When running the pipeline I obtain the following:

However I am on the Katalon TestCloud Free Trial plan so it should be working. My Katalon Runtime Engine license is successfully activated.

What is going on?

1 Like


I will ask my team about your case and back to you soon

@irelandjj Did you declare orgID in the KRE command lines? Please share us that line. The TestCloud license is fetched based on orgID that you input in the command lines.

Hi @ha.tpham this is what my yaml file on my Azure DevOps pipeline looks like. I added the orgID which was missing but still getting the exact same error with Exit code 3.

- main

  vmImage: ubuntu-latest

- task: katalonTask@1
    version: '9.2.0'
    executeArgs: '-retry=0 -testSuitePath="Test Suites/TestSuiteOne" -browserType="TestCloud" -testcloudEnvironmentId="300" -testcloudTunnel="false" -executionProfile="default" -apiKey="xxxx" -licenseRelease="true" orgID="xxxx" --config -webui.autoUpdateDrivers=true'
    xvfbConfiguration: '-a -n 0 -s "-screen 0 1024x768x24"'
    JAVA_HOME: $(JAVA_HOME_17_X64)
    PATH: $(JAVA_HOME_17_X64)/bin:$(PATH)
  displayName: 'Katalon test run on TestCloud'
- task: PublishPipelineArtifact@0
    artifactName: 'JUnit Report' 
    targetPath: report/

@irelandjj Found that your command lines are missing ’ - ’ before orgID. Please recheck. Example as below

1 Like

Hi @ha.tpham , thanks for that, my bad. Now I am successfully able to activate the TestCloud license from my pipeline. However there is the following error later on which seems still related to the organization ID. What is that issue?

Katalon version: 9.2.0
Plugin info URL: https://store.katalon.com/api/products/ks?appVersion=9.2.0&appType=ENGINE&licenseType=TRIAL

Start checking license task

com.kms.katalon.execution.exception.ExecutionException: java.lang.NullPointerException: Cannot invoke “com.kms.katalon.entity.integration.analytics.AnalyticsOrganization.getId()” because the return value of “com.kms.katalon.integration.analytics.setting.AnalyticsSettingStore.getOrganization()” is null

Hi @irelandjj, this error is caused by no access permission to the project that you inputted. Please open Settings > Platform Integration and recheck the project that you selected whether you have access permission to it or not.

My bad again, I had done that but had not pushed my changes to the test repo. Thanks!

hi @ha.tpham I got the issue with error when I run KRE with Azure:

	at javax.xml.bind.DatatypeConverterImpl.guessLength(DatatypeConverterImpl.java:654)
	at javax.xml.bind.DatatypeConverterImpl._parseBase64Binary(DatatypeConverterImpl.java:692)
	at javax.xml.bind.DatatypeConverterImpl.parseBase64Binary(DatatypeConverterImpl.java:434)
	at javax.xml.bind.DatatypeConverter.parseBase64Binary(DatatypeConverter.java:342)
	at com.kms.katalon.util.CryptoUtil.decode(CryptoUtil.java:86)
	at com.kms.katalon.application.utils.ActivationInfoCollector.releaseLicense(ActivationInfoCollector.java:913)
	at com.kms.katalon.console.handlers.ActivationHandler.releaseLicense(ActivationHandler.java:197)
	at com.kms.katalon.console.handlers.ActivationHandler.activationWithTestOps(ActivationHandler.java:228)
	at com.kms.katalon.console.handlers.ActivationHandler.activate(ActivationHandler.java:273)
	at com.kms.katalon.console.application.ConsoleMain.launch(ConsoleMain.java:108)
	at com.kms.katalon.console.application.ConsoleApplicationStarter.start(ConsoleApplicationStarter.java:36)
	at com.kms.katalon.application.Application.runConsole(Application.java:125)
	at com.kms.katalon.application.Application.start(Application.java:88)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1447)

Hi @trankhoa0702 Please give us more details of your error? Which environment did you execute? Local or TestCloud?