When switching to window index 2, katalon is failing to make any click on the screen

i’m trying to automate dynamics 365, and i have succeeded in doing so, but after finishing the processes, i was asked to search for the created cases from the advanced find. and here where my problem began. i did a query to find the intended case, but when i click on the case from the results of the advanced find, i have added switch to window index 2, then maximize the window, till now everything is fine, but after the maximize window, katalon is failing to make any click on the screen. any help?

Do you see any errors?

What happens if you remove the maximize window?

no there is no error, katalon just move to the next step, and nothing happens on the screen. i don’t think the problem is from maximizing the window, because i did remove the maximize window and nothing changed

Are you certain about window index 2?

Try 1.

i tried index 1, the focus went to the advanced find screen and not the opened case.

i did something, close windows index 0 (which is CRM main page), which made the advanced find window index 0 now and then i did switch to windows index 1 (the window of the case), but still no luck, katalon is not able to make any click on the screen

I would avoid doing that.

Did you try WebUI.switchToWindowTitle()

yes i did try the switch to window title, but katalon failed to specify which window to go to. and i tried switch to window URL as well, but also no luck

Show me a screenshot and mark the three windows so I can see what is going on.

the first one is the CRM main page, the second one is the advanced find and the third one is the case window

Katalon doesn’t specify which window, you do that in your test case.

i don’t specify the window, but when i put switch to window title, the 3 windows become flickering and no window was chosen, as if Katalon didn’t know what window to choose

Do you think it might be a timing issue? Make sure you wait long enough for the window to appear and load its content.

i did add delay 3, and the page was actually loaded

the issue was solved, i had to do some changes in the iFrame, issue was detected with the Spy object