Version 7.1


#1

This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/new/version-71.html

#2

Some API test scripts are not getting passed in V 7.1 which were passed in v 6.33.
In V 6.33, Follow Redirects is not functional
However, this is working in V 7.1.

I am using Fiddler to figure out what the issue is, the raw request sending is expecting an empty line after the request headers.


#3

I have the same issue with API test script.
When I run my test case in test suite, variable still empty even though I have map the variable using excel data files.
Can someone help me with this issue?


#4

Hi @vooha.nallamothu,
In v6.3.3, we only follow redirect if the “Follow redirects” option is enabled and the response status code is 301, 302 or 303. In version 7.1, we also support redirection for status code 307 and 308. I suspect that may be the reason why some of your test scripts passed in v6.3.3 but does not pass in v7.1.0, because those that failed may have response with status code 307 or 308.
Please help to check this again by disabling “Follow redirects” option in the configuration tab of the web service object view and try send the request again to get the response status code without redirection.
Regards.


#5

Hi @dewikm411,
Can you share your project? You can send it in private via forum mail.


#6

Hi @huynguyen,
In v 6.3.2, I have tried disabling the follow redirects, but still the redirection is happening for me. The status code for them is 302 only


#7

Hi @vooha.nallamothu,
Please send us your request object file (.rs file) together with the HAR file generated with both versions 6.3.3 and 7.1.0
Regards.


#8

Could you please send your email Id, so that I can share


#9

Hi @vooha.nallamothu,
Please send using forum mail.
Regards.