Version 7.0

My Old Version was 6.3.3. and Now i have Install and using 7.0.3. But i am facing issue for Delay function.

using Delay across all the Script
WebUI.delay(findTestData(GlobalVariable.GLOBAL_ENV).getValue(‘ShortDelay’, 1))
WebUI.delay(findTestData(GlobalVariable.GLOBAL_ENV).getValue(‘MediymDelay’, 1))

Getting Below Error for 7.0.3 But Not for 6.3.3 Please some one Help for this.
2019-10-25 15:58:09.402 ERROR k.k.c.m.CustomKeywordDelegatingMetaClass - :x: groovy.lang.MissingMethodException: No signature of method: static com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords.delay() is applicable for argument types: (java.lang.String) values: [4]
Possible solutions: delay(java.lang.Number), delay(java.lang.Number, com.kms.katalon.core.model.FailureHandling), getAt(java.lang.String), every(), any(), dump()
2019-10-25 15:58:09.424 ERROR c.k.katalon.core.main.TestCaseExecutor - :x: Test Cases/Platform_TestCases/Wire/Repetative/Create_Edit_Approve_Delete_USWire_RepetativePayment_Audit FAILED.
Reason:

Not sure what has changed in both Version. Please Share Quick Solution

One More issue with 7.0.3 Version, if you Write or Create any Custom Keyword in Using 7.0.3 Version and Launch Same Project with 6.3.3 Newly Created Custom Keyword does not show in Application, it is present under Folder of your local machine but does not reflect with older version

Hi there,
I have updated Katalon today to 7.0.4 version (not Beta, MacOS User) and I cannot login to my Katalon Account with my password. It shows this error Katalon_Account%20ID%20error
I can log in with these credentials in https://www.katalon.com/ here in the community and in katalon analytics. I don´t type the password. It is saved in the saved logins in the browser and also I have copied and pasted it from there. Has anyone else the same problem? I cannot use TestOps (the reason of the upgrade)

exactly same problem with version 7.0.3 on windows

Yes experiencing the same issue. Started discussion here: How to use TestOps in KS 7.0.1

Debug mode execution is no longer available in 7.0 version of the Katalon studio release. It would be great if this is fixed in the minor releases. Thanks.

Execution of test cases in debug mode is no longer available in version 7.0. Will this be fixed in upcoming versions? Is there a way to run test cases in debug mode with version 7.0?

Hi @vish3621

Debugging mode is now only available with KSE, you can have a free trial period. For details regarding the differences between KS and KSE, please refer to the following link:

Hello @aggeliki.rabaouni

Unfortunately, offline activation is currently not supported in KSE and RE trial license. If you want to connect to Katalon TestOps, you need to online activate it. On the top right corner > Account > Deactivate > Reactivate.

Jass

Any idea why after updating to 7.0.4 my project file disappeared - there is no source code anymore?

How to update the latest version 7.0.3? It shows that there is an update available under about katalon however ‘check for updates’ under Help is not available. I am using Katalon 7.0.1. Thanks!

Hi Jass,
Thank you for the help on this issue. The only thing I would like to add here is that while I was trying to reactivate the Activate button was not enabled the first two times and Katalon crashed both times. I repeated this three times and at the end I managed to activate the account again.

Does anyone else here have issues integrating with Kobiton on version 7? When I go to my integrations it’s basically blank and I can’t do anything there? Tried reinstalling Katalon but still the same issue.

@ismail.mee You need to manually download the latest version by going to Katalon-studio website. There is a bug in 7.0.1 and it doesn’t have ‘check for updates’ button.

1 Like

Oh good to know @Bhawna_Rani. Thanks for the reply though!

iam cannot running my test case after update to katalon version 7, after i click execute and nothing happen than test suite auto terminated

Latest release 7.2.6:
after a feature file runs, I get an error :

Reason:
com.kms.katalon.core.exception.StepFailedException: Keyword runFeatureFile was failed (Root cause: java.lang.NoClassDefFoundError: org/junit/runner/Result

How can I solve the problem ?

Latest Version: 7.5.1.1

Incognito mode doesnt work for chrome, it just brings up a normal window

@dstride1980

Please try again with v7.5.2: