Katalon Studio Version 7.0


#1

This version does not fully support scripts from Version 6 x.x . The moment i run my script on the previous version, it breaks at some point because its unable to locate the element. I verified the elements properties, id, selectors and even captured new one with version 7 but still fail. I like the added feature of Katalon 7.0. but its not of any use to a professional when it fails or breaks on most part of the scripts. Maybe the final version on Katalon 7 would be better. As for now…my code has been breaking. It will pass from beginning and fail the step on some points. All the my objects are well captured, well set…but it still fail.


#2

@lifelogicsautomation I think this can’t be the case. There must be something else making your test case fail.

Have you tried going back to last stable release and seeing if the same is working over there ?


#3

@lifelogicsautomation

Can you provide a concrete example ? I doubt new versions of Katalon makes your object localization fails, but there’s no evidence for that doubt either. Please provide a description of what worked stably on early versions and becomes unstable on 7.0.0.


#4

and kindly follow the guidance on the pinned post on ‘how to ask for help’.
i will not provide the link on purpose, please search for it.
(hint: is pinned … or i already said that?)


#5

I was just using Katalon in my bitbucket pipeline with 6.3.3 and all of a sudden, when I run it now, it is pulling version 7.0 and complaining that I have no license.

Anyone know if I can tell the pipeline which version of Katalon to use?

HELP!!


#6

@Yaacov_Silverstein what exactly contains your pipeline? you run katalon via docker, or how?

HELP US TO HELP YOU!!!


#7

I run in it with docker using katalon image.

The bitbucket-pipelines.yml file as the following:

pipelines:
default:

  • parallel: # these 2 steps will run in parallel
    • step:
      services:
      - docker
      image: katalonstudio/katalon
      script
      - katalon-execute.sh -browserType=“Chrome” -retry=0 -statusDelay=15 -testSuitePath=“Test Suites/POC_AC_SELLER” -reportFileName=“Junit.xml” -apiKey="…"
      after-script:

#8

I believe that I am facing the exact same issue as Yaacov_Silverstein, although our CI pipeline is based on Teamcity. We have a Teamcity project which runs Katalon command line in a Docker container. The problem seems to be a missing License…

Please help, and hopefully explain how to obtain/register a License for running Katalon Studio 7 (not Enterprise) in command line mode with Docker in a CI-setup with multiple build agents (we have 10 Linux build agents being randomly assigned when a build is executed, so it would be very helpful if the License can accept all ten “Machine IDs”, and not be bound to just one…)

I see the following output in the logs:

[12:25:53] [Step 1/1] latest: Pulling from katalonstudio/katalon
[12:25:53] [Step 1/1] Digest: sha256:c7646247cbb060d22ec7169af2502393795e1779fd2807a2f104fc5446c4cadf
[12:25:53] [Step 1/1] Status: Image is up to date for katalonstudio/katalon:latest
[12:25:53] [Step 1/1] docker.io/katalonstudio/katalon:latest
[12:25:54] [Step 1/1] + echo ‘Starting Katalon Studio’
[12:25:54] [Step 1/1] Starting Katalon Studio
[12:25:54] [Step 1/1] + cat /katalon/version
[12:25:54] [Step 1/1] Google Chrome 77.0.3865.120
[12:25:54] [Step 1/1] Mozilla Firefox 69.0.2
[12:25:54] [Step 1/1] Katalon Studio 7.0.0

[12:25:59] [Step 1/1] INFO: Katalon Version: 7.0.0
[12:25:59] [Step 1/1] INFO: Command-line arguments: -retry=0 -statusDelay=15 -testSuiteCollectionPath=Test Suites/TSC-eb -apikey=***** -runMode=console -reportFolder=/katalon/katalon/source/report -projectPath=/tmp/katalon_execute/project/eb-webtest.prj*
[12:25:59] [Step 1/1] INFO: User working dir: /tmp/katalon_execute/workspace
[12:25:59] [Step 1/1] INFO: TestOps server URL: https://analytics.katalon.com
[12:25:59] [Step 1/1] INFO: Katalon Store server URL: https://store.katalon.com
[12:25:59] [Step 1/1] INFO: User home: /root
[12:25:59] [Step 1/1] INFO: Java vendor: Private Build
[12:25:59] [Step 1/1] INFO: Java version: 1.8.0_222
[12:25:59] [Step 1/1] INFO: Local OS: Linux 64bit
[12:25:59] [Step 1/1] INFO: CPU load: 0%
[12:25:59] [Step 1/1] INFO: Total memory: 7976 MB
[12:25:59] [Step 1/1] INFO: Free memory: 1617 MB
[12:25:59] [Step 1/1] INFO: Machine ID: d8ac88dbb0b058b50ff0ceddddfc0bc9
[12:25:59] [Step 1/1]
[12:25:59] [Step 1/1]
[12:25:59] [Step 1/1] Activating…
[12:25:59] [Step 1/1] Start activating offline…
[12:25:59] [Step 1/1] Finding valid offline licenses in folder: /root/.katalon/license
[12:25:59] [Step 1/1] The number of valid offline licenses: 0
[12:25:59] [Step 1/1] The number of Runtime Engine running sessions: 3
[12:25:59] [Step 1/1] License quota exceeded
[12:25:59] [Step 1/1] Offline activation failed.
[12:25:59] [Step 1/1] Start activating online…
[12:26:01] [Step 1/1] TestOps: Unexpected response code from Katalon TestOps server when sending request to URL: https://analytics.katalon.com/api/v1/license-keys/activate?machineKey=d8ac88dbb0b058b50ff0ceddddfc0bc9&ksVersion=7.0.0&email&sessionId=8d4e45c8-bd5c-4e85-937f-066d6908c3bc&hostname=8f63146f2cda&package=ENGINE. Actual: 500, Expected: 200
[12:26:01] [Step 1/1] An internal error occurred. Please contact your system administrator.
[12:26:01] [Step 1/1] Online activation for console mode failed.
[12:26:01] [Step 1/1] Activation failed. Please make sure you are using a valid license.


#9

that will always pull the latest. use repository/image_name:tag instead.
check for available tags here:
https://hub.docker.com/r/katalonstudio/katalon/tags

@oyvind.mo same for you, see:

[12:25:53] [Step 1/1] docker.io/katalonstudio/katalon:latest

ref’s:




Bitbucket Pipeline now pulls Katalon 7.0 and fails to run because of no Valid License
#10

Thanks for posting the workaround. I can successfully run my build by requesting
docker pull katalonstudio/katalon:6.3.3


#11

You guys saved the day! [Ibus] & [oyvind.mo]

Thnank you very much…works for me now too!!! :smiley:

For those with bitbucket yml file, just do this to get previous 6.3.3 version:

image: katalonstudio/katalon:6.3.3


#12

So the solution is to use the older version ?
How to get Katalon 7 working in docker ?


#13

same. pull the right tag


#14

Yeah ofc, question was how to handle katalon 7 + licence key + docker, aka how to inject the new mandatory licence key to the docker
I figure it out, you have to use -apiKey= param with your licence key as value

Ex in your pipeline:
katalon-execute.sh -browserType=“Chrome” -retry=0 -statusDelay=15 -testSuiteCollectionPath=“YourTest” -apiKey=${LICENCE_KEY}


#15

such confusions happens when the questions are not clear.
c’moon, it is not an IRC channel here, you have plenty of time to describe your issue before clicking on the ‘reply’ button :slight_smile:
your session won’t expire.

LE: and you can edit your post too if, after sumbitting, during the review (if you do such) you think that your post does not provide enough valuable info’s for the ones willing to help you.

LLE: hint - some people tend to simply ignore posts which are not clear.
me too, sometime. because why should i bother to figure out what you was asking if you don’t bother to provide relevant informations.
just saying