Using autoIT for authentication in Katalon Studio

This is a companion discussion topic for the original entry at


The sample you shown here is not working at all, when first executed the first line of WebUI.openBrowser(’’)… The IE/Chrome browser prompt you to enter credentials on popup windows.

However, it cannot proceed to the next line of code to get executed the autoit step… it always get pending there until if you close the credentials popup windows or press cancel button only able to proceed the autoit step.

//Sample path. Change it to your saved location of autoIT script
autoit_prj = ‘C:\Users\test-automation\Test_Credential.exe’

Could you please advice what is the right solution on this issue?

Do u have a solution to this. How do we use autoit for SSO authentication


The example specified above is not working, test case passed but expected action mentioned in test.exe is not performed. Please let me know if any solution is present.



Below is solution which works fine for me. While executing the AutoIt exe you can try with below statements -

Runtime runtime = Runtime.getRuntime()
Process process = runtime.exec(‘autoit_file_path_test.exe’)

Note: 1. Before executing the katalon’s test case of AutoIt test created AutoIt script once.
Pre-condition: Created AutoIt script must be open in SciTE Script Editor.
Steps :
1. Click on " Tools " from SciTE Script Editor.
2. Click on the " Go " option.
2. Make sure that the upload file window is opened on the background.

Both of above solutions are not working for me.
Katalon, what happened with WebUI.authenticate ??? It worked ok in previous version.

This solution worked for me … woooOO!

What happen when running in Chrome (headless), for me is not working. However in normal Chrome is working fine.
Any solution for headless? or one that is working for both situations?

Found kind of solution using Multipass Chrome Extension and keeping chrome profile. However rarely succeed, most time is failing:
Project -> Settings -> Desired Capabilities:
args -> List of Strings:

I am getting this issue in IE only. I have used authenticate method for chrome and it worked

Anyone facing issue for IE?