Unable to upload run result from CLI

Hi Team ,

  1. Where is pie chart in KA

  2. Not able to upload run result as per below link
    https://docs.katalon.com/katalon-analytics/docs/project-management-import-cli.html

Error log :

C:\Users\xxx\Downloads> java -jar katalon-report-uploader-0.0.5.jar --kit.server.api=https://analytics.katalon.com --projectId=28298 --path=“C:\Users\xxxx\git\xxxx.QAAutomation\Reports\Dry Runs\01 Functional Testing\01_UI Test Scenarios\20190718” --email=xxxx@xxx.com --password=xxx(Key) --type=katalon
2019-07-19 16:32:12.176 INFO 3608 — [ main] c.k.k.r.uploader.UploaderApplication : Starting UploaderApplication v0.0.5 on 3RF4362 with PID 3608 (C:\Users\xxx\Downloads\katalon-report-uploader-0.0.5.jar started by xxx in C:\Users\xxx\Downloads)
2019-07-19 16:32:12.192 DEBUG 3608 — [ main] c.k.k.r.uploader.UploaderApplication : Running with Spring Boot v1.5.3.RELEASE, Spring v4.3.7.RELEASE
2019-07-19 16:32:12.193 INFO 3608 — [ main] c.k.k.r.uploader.UploaderApplication : No active profile set, falling back to default profiles: default
2019-07-19 16:32:12.304 INFO 3608 — [ main] s.c.a.AnnotationConfigApplicationContext : Refreshing org.springframework.context.annotation.AnnotationConfigApplicationContext@536aaa8d: startup date [Fri Jul 19 16:32:12 EDT 2019]; root of context hierarchy
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.springframework.cglib.core.ReflectUtils$1 (jar:file:/C:/Users/xxx/Downloads/katalon-report-uploader-0.0.5.jar!/BOOT-INF/lib/spring-core-4.3.8.RELEASE.jar!/) to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
WARNING: Please consider reporting this to the maintainers of org.springframework.cglib.core.ReflectUtils$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
2019-07-19 16:32:13.900 INFO 3608 — [ main] o.s.j.e.a.AnnotationMBeanExporter : Registering beans for JMX exposure on startup
2019-07-19 16:32:14.614 DEBUG 3608 — [ main] c.k.k.report.uploader.helper.HttpHelper : Request: POST null/oauth/token HTTP/1.1
2019-07-19 16:32:14.644 ERROR 3608 — [ main] c.k.k.r.u.h.KatalonAnalyticsConnector : Cannot get access_token from server by your credentials

org.apache.http.client.ClientProtocolException: null
at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:187) ~[httpclient-4.5.3.jar!/:4.5.3]
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:83) ~[httpclient-4.5.3.jar!/:4.5.3]
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:108) ~[httpclient-4.5.3.jar!/:4.5.3]

Hi @vikrant.a202

  1. Due to the UI changed, the pie chart was already removed.
  2. Please try the following steps and check whether you still have that issue.
    a. Try logging in those Katalon account credentials on a browser.
    b. Make sure you upload test results to the intended project.

If you can successfully log in Katalon Analytics, please check if your Katalon report uploader has the latest version’s update. And then remove kit.server.api=https://analytics.katalon.com from the syntax.

If you cannot log in, please provide screenshots of your steps.

Good luck,

Jass

Still not working

  1. Project Set up

  2. Project Screen as new

  3. Command tried to upload result [Note below Command tried with both password and AppKey ]

java -jar katalon-report-uploader-0.0.5.jar -projectId=30763 --path=“C:\Users\XXXXXX\git\Unison.QAAutomation\Reports\Dry Runs\01 Functional Testing\Treatments\01_UI Test Scenarios\20190813_152442” --email=XXXX --password=XXX --type=katalon

As per log I am using latest available Jar

1 Like

Hello @vikrant.a202,

Thanks to your screenshots, we found out that for the first time, you may enter the wrong project ID which causes the failure in uploading test results by Command-Line.

For the second time with our instructions, the failure came from the removal of this kit.server.api=https://analytics.katalon.com
So please put it back into the syntax and make sure with the right project ID.

Hope it works!

Jass

I’m receiving the exact same error.
I have checked my project ID and credentials. I have also added/removed kit.server.api=https://analytics.katalon.com. But it’s still not working

1 Like

Hello @jsmn,

Could you please provide some screenshots of the steps you took so we can investigate your case?

Jass

It didn’t work , could you please try at your end as well :confused:

After running this command, I get the same error that vikrant.a202 had in the original post.

Hi @vikrant.a202,

As can be seen in your screenshot, there was a mistake in your command that led to the error: " Unable to access jar file". To correct that, you need to specify jar file value right after java -jar

java -jar katalon-report-uploader-0.0.5.jar kit.server.api=https://analytics.katalon.com...

and also the -type=katalon should be modified as --type=katalon.

In your first post, the error was “Cannot get access_token from server by your credentials”.

Regards,

Jass

Hello @jsmn

Please provide us with your screenshot or error log for further investigation.

Jass

Hi @jsmn

We have already tried your command and still succeeded. Please try downloading another Report Uploader and let see if you can manually upload reports to Katalon Analytics.

Jass

Hi Jass,

if you see @jsmn previous screenshot we are already using latest one , and I doubtful about using any other jar as Katalon analytics is already being changed lot from design and template prospective.

if you still want us to try some specific version do let me know