Not able to Upload reports from Katalon CLI

Hi All,

I’m trying to Upload the reports from CLI. While executing the code it sends the file but showing status 302 (URL redirection). I’m using the latest version 5.10.1.

Using code in CLI:
java -jar ./katalon-report-uploader-0.0.1.jar --kit.server.api=http://analytics.katalon.com --projectId=155 --path=“D:\Git\Katalon\BddAutomation.prj\Reports” --email= --password=

Thanks in Advance…

Hi @Akhil,
Please try with https://analytics.katalon.com in kit.server.api. Katalon Analytics is using https protocol instead of http. If you have errors with https, please capture the picture and send us for deeper investigation.

Hi @Thong,

It’s working now. Thanks for the help…

Hi @Thong,

I can execute the command from CLI to upload the reports but in katalon analytics it was executing with no results.

Thanks in advance

@Akhil,
Please provide me your project and username. We will investigate deeper.

Hi @Akhil,

Please try a new uploader version which supports for junit runner report format.
https://docs.katalon.com/katalon-analytics/docs/from-command-line.html#from-command-line

Hi @Thong

I’m following “https://docs.katalon.com/katalon-analytics/docs/from-command-line.html#from-command-line” to generate reports.

Used Command in CLI:

java -jar ./katalon-report-uploader-0.0.3.jar --projectId=** --path=“F:\MyReports” --email=123@gmail.com --password=123 --type=katalon

Reports are uploading in katalon analytics. But showing the empty reports. As shown below

If I upload the reports manually ( Import JUnit reports → choose files) it was showing the reports with scenario based.

I want to generate the report’s scenario based while running CLI.

These are the contents available in the MyReports folder.

contents

@Akhil
java -jar ./katalon-report-uploader-0.0.3.jar --projectId=** --path=“F:\MyReports” –email=123@gmail.com --password=123 --type=katalon

You need to change --type parameter to junit. Because the report is generated in jUnit format

That Works Perfect :slightly_smiling_face: Thankyou!

2 Likes