Unable to test a hybrid iOS app

I’m trying to test a hybrid app (React Native). I was able to test the Android version of the app on Katalon, but I’m having a problem to test the iOS version of the same app. Every time I tried to record/spy, my objects won’t be detected.

This post shows that Katalon currently only partially supports hybrid mobile apps, and Katalon’s Mobile Spy/Recorder doesn’t support to detect elements. But this kinda confuse me, because it worked for the Android version of the same app. I expect if it works on Android, it should work on iOS as well, vice versa.

I tried to follow a guide to detect iOS elements using Appium desktop, but apparently it showed the same thing–my elements are not detected.

Does anyone have any suggestions/explanation regarding this issue?


@Chris_Trevarthen @duyluong

Hi @nate321,

From what I’m reading about recording hybrid apps in Appium you can try a few things:

  1. First, always make sure the elements in the app have a testID and accessibilityLabel. That way Appium can find them.
  2. If the app is hybrid in that it uses a webview to render the contents, switch to the WebView context in the recording tool (I haven’t used Appium Desktop in awhile, so I’m not sure where this is located)
  3. Use Safari’s iOS developer tools to view the elements through Safari. See the section about “Webview/Hybrid/Safari app support” here: http://appium.io/docs/en/writing-running-appium/other/troubleshooting/

Hope this helps,