Unable to start application on iOS

Hi everybody
I am sure that you can help me
I’ve been trying to run ios testing for about a month now, and I’m sure I’m close to that
Thanks to you, now katalon can find devices in the device list and download it
At the moment I have the following problems and errors

  1. Problems starting WebDriverAgent
    a. If i run it through katalon - nothing works. WebDriverAgent don’t download automatically, and app is downloading, but don’t start
    b. If I start WebDriverAgent through terminal, I ran

    cd /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent sh ./Scripts/bootstrap.sh -d xcodebuild -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination 'id=xxx' test
    It’s not known why, I get different results: test failed, test succeeded and test interrupted (most common)
    After downloading WebDriverAgent on iPhone i need to trust to developer

  2. Problems starting the application
    Regardless of whether WebDriverAgent is installed or not, the application is installed on the phone, but it does not start

I’m quite tired right now, thats why I can write not enough correct
Thanks to you, hope finally I will deal with it