Unable to send email through Katalon studio

Hi,

I can’t send email throught katalon studio

I try with the port : 465, 25

This is my error :

log :

!ENTRY org.eclipse.e4.ui.workbench 4 0 2018-04-25 09:40:41.602
!MESSAGE
!STACK 0
org.apache.commons.mail.EmailException: Sending the email to the following server failed : smtp.gmail.com:465
at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1421)
at org.apache.commons.mail.Email.send(Email.java:1448)
at com.kms.katalon.execution.util.MailUtil.sendTestMail(MailUtil.java:74)
at com.kms.katalon.composer.execution.settings.MailSettingsPage$11.run(MailSettingsPage.java:390)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
Caused by: javax.mail.MessagingException: Exception reading response;
nested exception is:
java.net.SocketException: Connection reset
at com.sun.mail.smtp.SMTPTransport.readServerResponse(SMTPTransport.java:1462)
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1260)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:370)
at javax.mail.Service.connect(Service.java:297)
at javax.mail.Service.connect(Service.java:156)
at javax.mail.Service.connect(Service.java:105)
at javax.mail.Transport.send0(Transport.java:168)
at javax.mail.Transport.send(Transport.java:98)
at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1411)
… 4 more
Caused by: java.net.SocketException: Connection reset
at java.net.SocketInputStream.read(SocketInputStream.java:209)
at java.net.SocketInputStream.read(SocketInputStream.java:141)
at sun.security.ssl.InputRecord.readFully(InputRecord.java:465)
at sun.security.ssl.InputRecord.read(InputRecord.java:503)
at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:973)
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)
at sun.security.ssl.SSLSocketImpl.readDataRecord(SSLSocketImpl.java:928)
at sun.security.ssl.AppInputStream.read(AppInputStream.java:105)
at com.sun.mail.util.TraceInputStream.read(TraceInputStream.java:97)
at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
at java.io.BufferedInputStream.read(BufferedInputStream.java:265)
at com.sun.mail.util.LineInputStream.readLine(LineInputStream.java:75)
at com.sun.mail.smtp.SMTPTransport.readServerResponse(SMTPTransport.java:1440)
… 12 more

I test several solution in this forum, but i stay lock
Can you help me

Capture.PNG

Have you tried disabling your antivirus? It worked for me…

Thanks Bojan

I find the solution, it’s autorise my computer to Exchange admin server

Katalon Studio 64 Bit v5.4.1 - No Email Sent After Test Suite Runs

See attached MS Word file with screen shots of various Katalon Studio settings…

Katalon Studio 64 Bit v5.4.1 - No Email Sent After Test Suite Runs.docx

Katalon Studio Windows 64 v5.4.1 - Email Notification Fails to Send if Attachments are Included

PC running Windows 7

News:

On Katalon Studio Windows 64 v5.4.1, if the Project Settings - Email - Report Format - “Include report as email attachment” check box is checked, no matter which additional check boxes are checked or unchecked (HTML file; CSV file; PDF file; Log files ), no email will be sent after a Test Suite is run…

The only way to receive an email after a Test Suite is run, is to avoid checking the Project Settings - Email - Report Format - “Include report as email attachment” check box…