Unable to remove/delete object from the object repository.


#21

I hope it gets fixed soon too as well. Crossing my fingers.


#22

Currently using KS 5.4 on Windows 7. I have noticed when attempting to delete an object nothing really occurs within the KS ‘Test Explorer’ or the Windows Explorer. So the delete function does not appear to work within KS. When attempting to rename an object an error message displays informing me “Unable to rename Test Object.”. Now from this I have noticed within the Windows Explorer side the object actually does get renamed and refreshing the KS Test Explorer does not seem to help identify this. Here have been my work around steps for this until this bug is resolved:

  1. DELETE test object, right-click on the object and select ‘Open containing folder’ and delete the object from the Windows explorer. Go back to the KS Test Explorer and refresh the folder or project (Ctrl + F5).
  2. RENAMING test object, press F2 rename the object. Upon receiving the error click ‘OK’ and press F2 and rename the object the exact same way again. The second time always works, unless you rename differently again. Very odd.

This is a big pain when trying to manage a large object repo., hope this is resolved soon!

Jeff K.


#23

Todd Bruss said:

With the project that is “corrupted”, I cannot move Repository objects in it from within Katalon Studio. Unable to move the selection: null

I tried making sure none of the directories and files are read only. some where but setting them to be read/write did not seem to help.

Wish there was tool that could go in an validate the project and fix any issues*.

*I found a good workaround to this problem. What I did was copy all my repository objects from within Katalon Studio, creating a new project and pasted the objects, it copied all of them and allow me to delete and move again.

Todd Bruss - from what I have noticed is the object actually does move folders on the backside but does not inform the KS Test Explorer correctly for some reason. I use Window 7, and would get this error and would check the Windows Explorer folder to see if it was being move, and in fact they were. When I did a folder refresh or project refresh the Test Explorer would update the objects to the correct folders… I know this doesn’t help with the bug you’re receiving, but I thought I would share my observations…


#24

I am experiencing exactly the same situation referenced above. I am using Windows 10 and KS 5.8.0. I noticed this two revisions back and hoped that each new release would fix the issue. The only workaround I have been using is to move objects in Windows Explorer and refresh Katalon, however this does not always work, sometimes I have to close Katalon and reopen it just to see changes. Still awaiting a fix and hopefully a fix is available soon.


#25

Hi, I am also experiencing problems with the inability to remove Object from Repository. I checked on three versions of KS ( 5.9.1, 5.6.3 and 5.7.1) . The only way, that I found, to delete Object from Repository, is to directly remove it from the Project folder.
Yes I know, It’s not how it should be.


#26

Hi,

I’ve got a got a folder in the Object Repository where I can’'t see the web element, but I can use them in test cases and everything works fine. I have folders where I can’t rename or move the web elements.
The only way I can modify the web elements is to go in the source folder.

I’ve tried to copy files in a new project but it still doesn’t work.


#27

Has there been any movement on this from Katalon’s side? I am now experiencing this issue and it is a fairly big grievance for us.


#28

This worked for me - thanks :slight_smile:


#29

If you right click and click on open containing folder - then delete it from there - go back to katalon and refresh the folder/repository it used to be in and it should be deleted. It worked for me, hope it helps