Unable to execute tests on IE 11

Hi all,

We are still unable to execute tests on IE 11 after configuring that as per
IE config
What happens is that the browser gets launched but can’t load the page and stays blank.

As a result tests fail. Would you have any suggestions ?


1 Like

Hi there,

Please provide your test case up to the step which is having that issue as I can’t reproduce it from my side.



I am also facing above issue when running test cases in IE. Please solve the issue ASAP.


Can you post for me the error message displayed for failed test ?

hi…We are also facing the same issue in IE.

Unable to run in IE…any suggestions.

Only occurs in IE.

I performed all the configuration steps.

able to record test in IE

Not able to run test in IE get the following message

Root cause: org.openqa.selenium.WebDriverException: java.net.SocketException: Connection reset

1 Like

Root cause: org.openqa.selenium.WebDriverException: Failed to navigate to {url}. This usually means that a call to the COM method IWebBrowser2::Navigate2() failed.

Figured out:
1. In Katalon - go to Project -> Settings -> Execution -> Default -> IE – click on Add and add these values {name = ignoreProtectedModeSettings, type = Boolean, value = true}
2. Followed steps here - https://docs.katalon.com/display/KD/Internet+Explorer+Configurations
3. Instead of checking the Protected Mode – just unchecked the protected modes for all zones including in advanced.

Then my script execution is all good. Please could all of you who had issues please retry and let me know if above is working in your systems too. Thank you

1 Like

Use WebUI.openBrowser(‘url’) then it will lauch your application. WebUI.navigateToUrl method is not working with ienot

I have the same issue too… The error is : java.net.SocketException: Connection reset
This happened when I tried to start Web Spy with IE too.

I tried the approaches mentioned above but seems not working for my case.

I’ve resolved this issue as below:
Enable protected mode for Internet, Local Internet, Trusted sites and restricted sites respectively.

The instruction in the Manuel gave me an impression that I only need to enable the mode for Internet. But that does not work for me until I enabled the mode for all the four zones.

Hope this could help.

I ran into this as well. The issue I was running into is that I had protected mode selected in all the zones within Internet Options. Once all of those were “unchecked” the typing went the expected speed. However the time inbetween each object is still quite slow. Chrome works a lot better but unfortunetely I have pages that only work in IE that I’m testing.

unchecked the protected mode selected in all the zones within Internet Options is quite risky. Am i right? I tried to used this kind of method but I’m too hesitated to try it. Does your IE has any issues after you unchecked all the protected mode?