Unable to create a new remote session - Could not find a driver for automationName 'uiautomator2' and platformName 'android'

Hello. I’m attempting to record a mobile automation on an emulator, pretty much just following the tutorial.
I have the following installed:

  • Appium 2.5.1
  • Node.js v21.1.0 / npm 10.2.0
  • .NET SDK 9.0.100-preview.1.24101.2
  • java version “17.0.9” 2023-10-17 LTS
  • Android Studio (for the emulator)

And then I’m hit with this error from Katalon. Anyone can provide a solution? Thanks.


Try installing the uiAutomator2 driver for Android.
using the command - > appium driver install uiautomator2

if you face the same after installing it
pls share the capability you are using and the appium version here.


Thanks a lot, that worked. You’ve just saved a guy’s job application.

1 Like

please mark it as a solution for future reference

I have installed it but it still doesn’t work?

Hi there,

Thank you very much for your topic. Please note that it may take a little while before a member of our community or from Katalon team responds to you.