Unable to activate Katalon License

I used to work with Trial version of Katalon and I have a license now and I use the same account with email ID I used to use in Trial version. But when I open the Katalon and click on notification icon, it says that your Enterprise trial has experied. You are using the community Katalon Studio license with limitations of features and support. My email id has added in Registered User List.

I downloaded latest version of Katalon Runtime Engine also, it doesn’t work either.

All the BDD test were also not running now and getting following error,
Keyword runFeatureFile was failed (Root cause: java.lang.NoClassDefFoundError: List
at cucumber.runtime.java.MethodScanner.scan(MethodScanner.java:40)
at cucumber.runtime.java.JavaBackend.loadGlue(JavaBackend.java:82)
at cucumber.runner.Runner.(Runner.java:36)
at cucumber.runtime.Runtime.(Runtime.java:65)
at cucumber.runtime.Runtime.(Runtime.java:46)
at cucumber.runtime.Runtime.(Runtime.java:42)
at cucumber.api.cli.Main.run(Main.java:34)
at cucumber.api.cli.Main$run.call(Unknown Source)
at com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords$_runFeatureFile_closure1.doCall(CucumberBuiltinKeywords.groovy:76)
at com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords$_runFeatureFile_closure1.doCall(CucumberBuiltinKeywords.groovy)
at com.kms.katalon.core.keyword.internal.KeywordMain.runKeyword(KeywordMain.groovy:68)
at com.kms.katalon.core.keyword.internal.KeywordMain$runKeyword.call(Unknown Source)
at com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords.runFeatureFile(CucumberBuiltinKeywords.groovy:46)
at com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords$runFeatureFile$0.callStatic(Unknown Source)
at com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords.runFeatureFile(CucumberBuiltinKeywords.groovy:169)
at com.kms.katalon.core.cucumber.keyword.CucumberBuiltinKeywords$runFeatureFile.call(Unknown Source)
at WSVerification1597114088942.run(WSVerification1597114088942:2)
at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
at com.kms.katalon.core.main.WSVerificationExecutor.runScript(WSVerificationExecutor.java:146)
at com.kms.katalon.core.main.WSVerificationExecutor.doExecute(WSVerificationExecutor.java:140)
at com.kms.katalon.core.main.WSVerificationExecutor.processExecutionPhase(WSVerificationExecutor.java:123)
at com.kms.katalon.core.main.WSVerificationExecutor.accessMainPhase(WSVerificationExecutor.java:115)
at com.kms.katalon.core.main.WSVerificationExecutor.execute(WSVerificationExecutor.java:103)
at com.kms.katalon.core.main.TestCaseMain.runFeatureFile(TestCaseMain.java:144)
at com.kms.katalon.core.main.TestCaseMain$runFeatureFile$0.call(Unknown Source)
at TempTempCase1597114084283.run(TempTempCase1597114084283.groovy:25)
Caused by: java.lang.ClassNotFoundException: List
… 27 more

How to fix this all these issues. Glad some help!



Please go to Katalon Studio > About and provide the screenshot of that dialog, it confirms the status of your current license.

Can you share more specifically what “doesn’t work” with Katalon Runtime Engine ? What have you tried, have you also obtained a valid KRE license yet ?

Regarding the BDD issue, please try to delete lib and bin folder in your project, re-open it to see if the same issue still appears.

Thanks ThanhTo for your reply.

BDD issue is got solved after deleting the Bin folder.

Yes I have the licence for the KRE. The VM that runs KRE has only KRE installed, not Katalon Studio. After extracted the KRE, I used KRE path and Katalon command to the test in CMD. It still throws licensing error. Unable to run the test Jenkins as well.
Do we need to have both KRE & Katalon studio inorder to run a test using command line or Jenkins?

I was able to solve all the issues related to Katalon Licenses. Thanks you ThanhTo.

1 Like