Test Suite: Execution stop after 23 Passed requests

Hello Katalon Users!

My problem is:

I have a Test Suite with Data Iteration (in this case 1-100) data from .csv file
I work with a SOAP request and input variables, which are filled from the csv.
If I run this Test Suite, the first 23 passes correctly, but the 24th request stops without any error message at the Console.
The problem is not the 24th test data, because I tried to execute only this one and it was run

Has anyone had a similar problem? What could be the solution?



If you duplicate the same SOAP requests 24 times (24 duplicate rows in the .csv file), then does all of them are execute successfully ?

I duplicated the same SOAP request (the 24th) in a new .csv file but the process was the same:
The first 23 request has run successfully, but at the 24th the execution stop without any errors.

Hi @Gabor.Probst,
Can you share with us your project? You can send in private using forum email.

Hi @huynguyen,
Could you write me how to send a private mail to you, because I could not find the page.

Thank you!


Hi @Gabor.Probst,
I have send an email to you. Please check your forum mailbox.

I tried to run the execution with Test Data.xlsx (not from .csv file), but the result was the same!
The running process stopped without any error message at the 24th request.

I imported a new SOAP request, which is different from the first one.
I created a Test Case, the input variables are also filled from .csv file.
I also created a new Test Suite, and when I ran that, at this SOAP request the first 19 passes correctly, but the 20th request stops without any error message at the Console.
As a reminder in the first Test Suite which is includes the first SOAP request, the execution stopped at the 24th test data.
So I think the source of the problem will be the SOAP request, but I do not know where.
Meanwhile I built up a database connection also, so I tried this branch, but the result was the same.

Does anyone have any ideas?

Thank You!

@hpulsford @Ibus

@Gabor.Probst keep an eye on the task manager when you run the tests, on the katalon processes.
it may reach mem-allocation limits so the process may crash or get stuck (note that, for each iteration, it will create new objects in memory and i am afraid the previous ones are not depleted).
you can try to edit your katalon.ini file and increase the values for Xms and XmX (take care when tuning them to not exhaust all available physical resources) to give more ‘playground’ in memory for the JVM and watch if anything changed.

@ThanhTo @devalex88 i think somebody should take a deeper look into this behaviour.
my bet up to now is on memory leakages.


Sorry for this issue. I just want to let you know that we are still working on it.

Please send us KS logs and other information (OS version, KS version, machine hardware specs).

I do not know what is meaning KS logs, I attached logs from the Reports map. It contains today’s run.
The execution always stops when the 24th request is sent.
The other SOAP Test Suite the result is the same, but here not the 24th request the problem.
At this case the execution always stops when the 20th request is sent.

My OS version:
Windows 10 Enterprise 64-bit 10.0.15063 build 15063
Hardware spec:
Intel® Core™ i5-6200U CPU @ 2.30GHz, 2400 Mhz
8 Gb RAM

Katalon Version:
7.08 but I know that it came out the 7.1.0. I tried the new version also, but the result was the same.


Reports.zip (3.6 MB)

1 Like

Dear Ibus,

I tested the memory status on task manager while the execution running, but there was no outstanding memory usage.
I have 8 GB RAM and Intel® Core™ i5-6200U CPU @ 2.30GHz, 2400 Mhz processor
I attached the katalon.ini file, my question is what can I modify in this file?

Thank You!
Regards,katalon.zip (347 Bytes)

1 Like


increase -Xms1024m to -Xms2048m (or even to 4096) and re-run. that is the setting for minimum (initial allocated) heapsize for JVM (java virtual machine)
re-run the test and see if any change, if is going further than previous steps, it may confirm this behaviour is caused by a certain memory-leakage in the katalon code (or wrong implementation of the garbage collector)

keep -Xmx4096m as it is (this is the max heap-size) to prevent your machine to get stuck.

of-course, restart katalon after you change this file …


I made the modification in the katalon.ini file, that you wrote, and also updated the Katalon 7.1.1 version.
The Test suite execution running is the same, the 20th request stops without any error message at the Console.

Unfortunately this did not solve the problem.

@Gabor.Probst so … let’s wait for the fix then from katalon dev team.
fingers crossed!

@Gabor.Probst Sorry for the issue. I just want to let you know that we are still trying to troubleshooting the project you sent us.

Thank You,
I’m waiting patiently


Hi @Gabor.Probst,
Can you send us your error log file? You can find it under Help > Error Log.