Test Suite Collection: navigateToUrl() not working


#22

I’m having a very similar issue even with the most basic test case. I’m using the suggested ‘autoit’ solution for login, removed using the Global Variable and it’s still not working.


When the browser window opens, I see it flicker for a second like it’s trying to navigate to the page but then it stays on blank browser screen. Looking at the LogViewer, it seems to think it successfully navigated:

Of course this all used to work. I believe this started happening after upgrading to V7.

I’m currently on 7.0.6.


#23

hello,

why not to use .properties files or .yaml files where needed variables are defined
this is only suggestion :slight_smile:


#24

@Timo_Kuisma1, sure, there are many workarounds. But as I am working mostly with people, who haven’t any devloper experience at all, I want to use the solution, that comes out of the box.
@Ibus sure thing. I am still hoping, that this problem is actually related to a simple mistake in the setup or something. But I cannot think of any. So please doubt further, maybe we’ll solve it like this.


#25

@Florian_Braun

How about doing just a simple debug print in the test case in the Test Suites/Debugging/DebuggingTestSuite:

import com.kms.katalon.core.configuration.RunConfiguration

WebUI.comment("You selected Execution Profile: ${RunConfiguration.getExecutionProfile()}")
WebUI.comment("GlobalVariable.G_URL_Home=${GlobalVariable.G_URL_Home}")

And see what you get in the console.


#26

Thank you for the report. If possible please try version 7.1.0 RC1 and let us know if it fixed the issue.


#27

Dear @devalex88: It seems that this issue is being solved in this version. Thanks a lot!

And many thanks to @Ibus, @kazurayam and @Russ_Thomas.

Best, Florian