Test scripts are failing in headless mode with exception "ElementNotInteractable"

Hi everyone,

First I am executing the testcase in katalon studio on normal browser and then once push the code to git, executing it from TestOps.

It is failing on TestOps with multiple reasons few i am able to resolve but not all.

Mainly errors are like “element click intercepted” ,I tried to resolve the issue by giving the statement

  1. WebUI.waitForElementClickable(findTestObject(‘Object Repository/Page_DemoBlaze/span_’),60)
  2. WebUI.click(findTestObject(‘Object Repository/Page_DemoBlaze/span_’))

I analyzed and found that the same issue when i run using headless mode on local as well. This issue araising due to headless mode runs bit faster than head mode and hence found the solution is wait for the element and click but still that is not working.

I found another solution for this is to configure disredcapabilities with --window-size=1920,1080 but still I am getting the same issue.

How i can resolve it? Thank you very much in advance!

1 Like

Hi,

I found this similar suggestion: Katalon says element not interactable - #2 by Dave_Evers. Can you please try?