Solution for the error "Unable to click on object"

I am using Katalon Studio Record and play to record the test cases but due to some issue when i am trying to play it, it gives me error
com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/Page_es Grade section codes/button_Close’ (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/Page_es Grade section codes/button_Close’
Need a fix
I have already tried solutions like waitForElement and delay techniques, as i am new to the automation testing.

We need to see the error log where it says “Caused by”.

Read this post - there is a lot of useful information to help you post better reports/questions:

1 Like

Thanks for you response
The post was also helpful
Here are screen shots of the error.

I think you missed this…

I’m away for most of today - maybe these guys can step in: @Brandon_Hein @kazurayam

Alright. Here it is.
Caused by: org.openqa.selenium.ElementNotInteractableException: element not interactable
(Session info: chrome=83.0.4103.97)
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:25:53’
System info: host: ‘S*******_S***0’, ip: '192.168..*’, ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_181’
Driver info: com.kms.katalon.selenium.driver.CChromeDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 83.0.4103.97, chrome: {chromedriverVersion: 83.0.4103.39 (ccbf011cb2d2b…, userDataDir: C:\Users\EDUBLO~1\AppData\L…}, goog:chromeOptions: {debuggerAddress: localhost:49854}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: WINDOWS, platformName: WINDOWS, proxy: Proxy(), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:virtualAuthenticators: true}
Session ID: 3479c26005a76419dea3c41486d7630e

This suggests the element is not interactable, try to add WaitForElementClickable before clicking the element to see if it helps.

Thanks Thanh To for the response.
I tried the method waitForElementClickable in the script as
WebUI.waitForElementClickable(‘Object Repository/Page_edublooms Home/button_Close’, 3)
but the result is same.
Caused by: org.openqa.selenium.ElementNotInteractableException: element not interactable
(Session info: chrome=83.0.4103.106)

Can you share the locator you are using in test object ‘Page_edublooms Home/button_Close’?

Another possibility is that you may be targeting a different element than the one you were expecting, and that element truly is not interactable.

The locator i’m using to test is in screen shot.

What Brandon is asking for, is the definition of the test object from Katalon’s Object Repository. Usually XPath, or CSS.

Oh I see
I think this attachment will do.

I don’t use XPath.

If you change the definition to use CSS, this will work:

#UpdateGradeSectionCodes1 .modal-footer button[type=button]

Be sure to WAIT until the button is ready.


This is a really really bad xpath (I’m assuming it’s from the recorder/object spy).

Try this one instead:


Just a note, that an XPath that should work would be:

id(“UpdateGradeSectionCodes1”)/div[@class=“modal-footer”]/button[@class=“btn btn-secondary”]

Also, if you try to copy and paste the above, you will have to fix “smart” quotes (quotes that have a curl or curve to them) that this forum supports but that KS does not.

Thanks for taking time to look into my problem, worth appreciation.
I tried all the above solutions you provided but some how I am still facing the same issue. I did some experiment with the xpath as well. But with no luck.
I’m wondering if someone can spear some time so we can fix this problem.

There’s an answer on StackOverflow suggesting it the modal is in another window. It’s not an accepted solution so I am not sure, however it’s worth trying:

You just need to substitute config.driver with DriverFactory.getWebDriver(), the logic should be the same.

Thanks Thanh To
The post on Stack Overflow suggests to switch to the modal window on which the error appears and also it says to apply wait for element method. I have already used these method
I am stuck here for days now. Better will be to escalate the problem to upper level so that I can set a zoom meeting with them.