Setup proxy manually with "Proxy Server requires authentication" don't work well

Hi everyone, I am newbie.
I want to test some web operations. In our network environment, there is an authentication proxy to connect to the Internet. So every tools to connect to the Internet are set up for authentication proxy.

1.I read a docs “Katalon Studio” > “Katalon Studio GUI” > “Preferences” > “Proxy Preferences”. And I set like the below settings.

Proxy Option : Manual proxy configuration
Proxy Server Type : HTTP
Address : Our proxy server address
Port : Our proxy server port(88)
Proxy Server requires authentication : checked
Username : My username for authentication
Password : My password for authentication

2.I make a very simple test case that there is only item open browser “https://www.google.com”.

3.Run the test case by Chrome.
Expected behavior :
1)Launch a Chrome Browser.
2)The proxy authentication dialog is not displayed.
3)The page “www.google.com” is loaded.
Actual result:
1)Launch a Chrome Browser.
2)The proxy authentication dialog is displayed.

What is wrong? Please anyone suggest to me!
4.My environment
OS : Windows 10 Professional 64bit
CPU : Intel Core i5-6500
Physical memory : 4GB
Chrome Browser : 72.0.3626.119
Katalon Studio : 6.0.4
5.Attachments
1)Proxy setting


2)Simple test case

3)Run by Chrome Browser

4)Launch Chrome Browser

5)Log on the Studio

6)Event log on the Studio

eventlog_infomation.txt (1.7 KB)
6.Simular issue on StackOverflow?

I would recommend you to try version 5.10.1 which is downloadable here

1 Like

Try Firefox and IE. Do they work?

1 Like

There is a similar issue which is still outstanding.

Katalon Studio seems to have problem passing username=******** to proxy.

1 Like

Thanks to kazurayam. This is a same issue. I hope to be improved it!

Firefox and IE ware also same behavior…

Thank you for your reply. To tell the truth, first of all I installed the version 5.10.1, but didn’t work well.

@patent-atanaka, Katalon Studio has not supported proxy authentication (http/https) when launching browser via web driver. We will consider about this issue, and will get you noticed soon if there is any update.
Regards.

1 Like

Thank huynguyen for your reply.I hope it.

try in this setting Project > Settings > Network. setting in your keystore and the keystore password, maybe this help you

1 Like

Hello guys ,
please I don’t know the proxy address to put here, is someone can help me to have this address right now ?

thank you for your feedback.
-_-