Running first scenario

Hi, I am new to katalon and I am trying to execute my first scenario. I am using the basic web sample script, but when I execute the script it seems that nothing is happening:

When I click on RUN the job is executed, but there isn’t any pass, fail or errors displayed. Actually, nothing happens.

The folder report is empty even after executed the test suite.

Any help is welcomed.





Problem solved!

It was hard to figure out, but finally I found the solution and run my first test.

I checked the katalon installation folder and found a log file under:


The message “Cannot connect to VM” was registered in the file. So, I added the following parameter on katalon.ini:

-vm C:\Program Files\Java\jdk1.8.0_131\jre\bin\javaw.exe

Voilà! Worked!


No, the console, log viewer and problems tabs are all empty.


I tried to debug and found these messages:

<terminated, exit value: 0>C:\Program Files\Java\jre1.8.0_131\bin\javaw.exe (30 de mai de 2017 15:39:47)

The JAR file (C:\…)\groove-all-2.4.7.jar has no source attachment.

I am still trying to solve it… Any help is welcome.



I uploaded the image on my google drive because I do not know how to attach image here.

Hi Vinh,

I’ve tried to run both the script and the testcase itself.


import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject
import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint
import com.kms.katalon.core.checkpoint.CheckpointFactory as CheckpointFactory
import as MobileBuiltInKeywords
import com.kms.katalon.core.model.FailureHandling as FailureHandling
import com.kms.katalon.core.testcase.TestCase as TestCase
import com.kms.katalon.core.testcase.TestCaseFactory as TestCaseFactory
import com.kms.katalon.core.testdata.TestData as TestData
import com.kms.katalon.core.testdata.TestDataFactory as TestDataFactory
import com.kms.katalon.core.testobject.ObjectRepository as ObjectRepository
import com.kms.katalon.core.testobject.TestObject as TestObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WSBuiltInKeywords
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUiBuiltInKeywords
import internal.GlobalVariable as GlobalVariable
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI
import as Mobile
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS

‘Open browser and navigate to a specific URL’

‘Click on ‘Book Appointment’ button’‘Page_CuraHomepage/btn_MakeAppointment’))

‘Input password’
WebUI.setText(findTestObject(‘Page_Login/txt_Password’), Password)

‘Click on ‘Login’ button’‘Page_Login/btn_Login’))

‘Verify ‘Make Appointment’ section is displayed after successful login’
landingPage = WebUI.verifyElementPresent(findTestObject(‘Page_CuraAppointment/div_Appointment’), GlobalVariable.G_Timeout)


As it is my first time with Katalon I am using the Sample web project.

Thanks for you help.

My tests has the same issue, how I can run the test? The webdriver is not oppening when I run the Test

Do you see any message on ‘Console’ tab after you’ve executed that test case?


Hi there,

Can you show me the screenshot of your Katalon Studio at that time?


Hi there,

Can you show me your script? When you execute a test case, no reports will be generated unless you execute a test suite.