Record with timeout bu default

Hello,

With the record interface of Katalon Studio, when i record Action with timeout (ex. “Verify Element Present”), the line is recorded with a value of timeout = 0.

But, when replay the scenario, that causes an error.
So, I have to complete each line with 0 timeout manually.

Could it be possible to record actions with a timeout by default, 5 by example?
So, I don’t have to complete it manually by default.
(the must : could set the timeout by default in katalon general properties :wink: )

Thank a lot,
CH

Hi Chivet,

You could try Setting -> Execution -> * **Default wait for element timeout ** -> set to 5. This is the default timeout period that Katalon Studio waits for the application under test to be loaded when executing the automation test.

Chris

Hello,

Thanks for your answer.
Unfortunately, it is not set the default value of timeout of VerifiyElementPresent command with the recorder.

Best regards,
CH

Now, it is ok. Thanks.