Project setting Web UI execution delay time / speed for more than 0 sec is incorrect


#1

Hello guys,

Here’s the summary of issue,

## Operating System: Windows 10

## Katalon Studio Version: Version: 5.9.1 Build: 2

## Environment (for Web testing): built in chrome driver

## Steps to reproduce

1. Go to Project> Settings > Execution > Delay between actions (in seconds)

2. Add value on that field (for example 1 or 2)

## Expected Behavior:

It should be exact 1 sec delay per step or 2 sec per step, depend on the value that I fill.

## Actual Behavior

The delay is more than expected time.

## Description:

I found an issue with Web UI execution delay time.

When I was performing the execution delay time with “0” second, it work really fast without delay (as expected). But the problem is, if I set the delay time to more than “0”, it become too slow.

For example, I set the delay time with “1” second, the delay be like 3 seconds (and this also found on the log report). Moreover with delay “2” second, it become 4 secs or more.

I’m pretty sure that I make the correct step to adjust the step by going to:

Project> Settings > Execution > Delay between actions (in seconds), and add value there.

If possible, I would like to suggest / recommend to make the time unit become ms / miliseconds. Because sometimes, there are some condition that maybe only need half second to continue to the next step.

I hope it will be updated soon, or if anyone have solution to me, let me know.

btw It’s my first post here, sorry if I’m wrong.

Thanks


#2

Thank you for the report. The option is mainly for debugging or presentation purpose. Could you please share your use case so that we can prioritize this request better?