Open Katalon Test Suite doesn't work

Hello*,

I have an external Tool that creat’s test suites for Katalon Recorder.

But Katalon Recorder will not import these test suites … there is no error message

I have created one simple test suite with katalon and then one with my tool, both test suites looks the same, the content is the same, both files are UTF-8 formated …

Can you please help me?

File that won’t work:
1.krecorder (748 Bytes)

File that works:
Test_works.krecorder (783 Bytes)

Hi @Kalle ,

This is an interesting issue. Let me try if facing same error and discover why.

The code is different in these two files. 1.krecorder is not a valid suite.

1 Like

so every command needs an empty „option„?
and also an „datalist„ Object even when there is no input?
Since when this is mandotory?

Maybee, there is the possibility that such an „import error“ could be shown in the log?

Possibly you should ask this question to the developer of the external Tool.

I have to ask myself, thats the problem.

sometime, the error is between the chair and the keyboard.

Lets go back to the topic: Is there a possibility that en error accours if you try to import a invalid suite?

There is no such topic.
You are developing a certain “external tool” and you complain the artifacts produced by this tool are not compatible with Katalon tools.
Is that fair to ask for the community support?

Show as the code of your ‘tool’ first.

What? Why are you conplaning?
I think it should be normal for every tool that if you try to open an invald element an error occurs

Is that fair to ask for the community support?

I havent asked the community for support, I asked if the developver can add an error message
All I want is an error if you try to Import an invalid suite …

Because you asked that nice: The “external” tool is a simple VBA (Macro) code, that creates a test suite to automate repeated tasks on a website.

Open File For Append As #1
Print #1, HTMLHeader & GoToTestPage
For i = 3 To LastRow
If Worksheets("Sheet1").Range("A" & i).Value = "True" Then
TestStep = Worksheets("Sheet").Range("C" & i).Value
ClickTestPage = "<tr><td>click</td><td>link=" & TestStep & "<datalist><option>link=" & TestStep & "</option></datalist></td><td></td></tr><tr><td>selectWindow</td><td>null</td><td></td></tr>"
Print #1, AddTestString & ClickApply & SelectWindow & ClickOK
End If

Next
Print #1, ClickApply & HTMLFooter
Close #1
Call AnsiZuUtf8Datei(File, True)

We really don’t need to see your VB code – we’ll leave that aside for now.

The best person to review this is probably @ThanhTo but I’m not sure if he’s around these days (maybe @sara.leslie can pass this along).

As to your suggestion that an error be issued for incompatible suite imports, I’d say yes. Let’s see what these guys think: @vu.le @vu.tran

Regarding the XML/XHTML in the image posted above, and the use of <datalist> elements (without associated <input> elements), that’s poor design on Katalon’s part. The <datalist> element is not allowed inside <td> elements, AFAICT.

Katalon Recorder is a free tool, the code is public.
You can find it here:

Not sure about opensource, it is mainly under Apache license but you have to read also the contribution agreement:

So, you can study it, figure out what is the issue, patch it and submit a PR.
That will be in the Comunity spirit.

Otherwise, just wait for a developer to look into this thread.

@ThanhTo

We need your help.

I tried reproducing the problem raised by the original post.

  1. I downloaded the 1.krecoder file
  2. I opened Katalon Recorder; chose the sidebar menu “Open KR Test Suite”.

  1. A file chooser dialog came up. So I chose the 1.krecorder file. And click OK.

  1. The file chooser dialog gently closed.

  2. Katalon Recorder did not load a Test Suite. It failed to because the file was mal-formed. I know the 1.krecorder file is malformed.

  3. KR did not display any error message. Apparently Katalon Recorder did nothing.

My proposal

I think KR should react with something visible (error messages, etc) in this situation.

@kazurayam @Kalle

another approach to get this fixed may be to raise a git issue on the source code i mentioned before.

you may have more chances to bring it to development team, instead of waiting for random reply on the forum.

just saying…

OK. I’ve done that

Got it, I was just curious how do you produce it, by rendering certain objects or by ‘raw’ string appending. Now I think I understand what you intend to achieve.

If you add the missing empty <option></option> and / or <datalist></datalist> does it work? Let’s try to locate which one is ‘offending’, only one of them or both.
After that, I think that may be a subject to another bug / git issue, since the ‘working’ html it is far away from being ‘standard’ but just strange.
If not, is even more strange, I don’t see any other differences between the two.

Sorry, I am known to be lazy so I am not in mood to install KR only for this.

Could be that the test case ‘input’ HTML is used as a template and is later manipulated by certain .js scripts or whatever else.
Just guessing, yet again, I am lazy to install KR and inspect further how this html is rendered by the application (and / or dig into the code)

LE: the source of the ‘load testcase’ functionality may be tracked from, hard to say.
Long time since I used .js, those seems to be some tests:

The import on top lead me here:

@kazurayam @Kalle
If I guessed right and the code is the one from my above post, looks like in such cases a certain message has to be logged in the console:

Can one of you repeat the test and watch if such is logged?
If yes, I suppose from here the first part will be easy, the developer (or a certain contributor) may only have to add an ‘alert’ since the error is already catched.

Thank you for the info.

I think that the console is not an appropriate place to output the message because I would NEVER look at the console when I am operating Katalon Recorder.

I personally think that the JavaScript Alert dialog is a poorman’s band-aid. The productional software should not use the Alert as a part of UI.

I think the KR developer was a bit lazy in handling the error which you pointed out.

I tried testing it, but I did not see any log in the Console tab of Chrome Developer Tools.

I am not sure where I should look at. Does KR has its own console apart from the one in the Developer Tools? I don’t know.