Not able to Record with iOS Emulators

Hi,

I am using katalan for mobile testing. We had both iOS and Android mobile app. we are facing the issues listed below with iOS

1. Whenever am trying to record the iOS app with recorder we are not able to capture the element.
2. Sometimes it’s not opening the App, it’s opening app followed by web driver agent and quitting the app
3. I recorded some steps with actual device and ran it on Emulator, the same issue repeats ( Sometimes it’s not opening the App, it’s opening app followed by web driver agent and quitting the app)

Note: Android is working smoothly without any hassles

Log for Recording fail:

[Appium] Welcome to Appium v1.7.2

[Appium] Non-default server args:

[Appium] port: 51462

[Appium] loglevel: info

[Appium] chromeDriverPort: 51463

[Appium] tmpDir: /var/folders/yj/vlb491dx4yg78m4ps4_dw51r0000gp/T//Katalon/Appium/Temp1521136324940

[Appium] Appium REST http interface listener started on 0.0.0.0:51462

[HTTP] → GET /wd/hub/status {}

[HTTP] ← GET /wd/hub/status 200 20 ms - 72

[HTTP] → GET /wd/hub/status {}

[HTTP] ← GET /wd/hub/status 200 13 ms - 72

[HTTP] → POST /wd/hub/session {“desiredCapabilities”:{“app”:"/Users/sivasankaramalan/Documents/Katalon Builds/iOS/R3/REALTrans.ipa",“automationName”:“XCUITest”,“deviceName”:“iPhone 8 Plus”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platformName”:“iOS”,“realDeviceLogger”:"/Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/tools/deviceconsole/deviceconsole",“udid”:“5B86B7C5-5AD8-4201-B604-60B260830AC9”,“waitForAppScript”:“true;”,“wdaLocalPort”:51533},“capabilities”:{“desiredCapabilities”:{“app”:"/Users/sivasankaramalan/Documents/Katalon Builds/iOS/R3/REALTrans.ipa",“automationName”:“XCUITest”,“deviceName”:“iPhone 8 Plus”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platformName”:“iOS”,“realDeviceLogger”:"/Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/tools/deviceconsole/deviceconsole",“udid”:“5B86B7C5-5AD8-4201-B604-60B260830AC9”,“waitForAppScript”:“true;”,“wdaLocalPort”:51533},“firstMatch”:[{“platformName”:“ios”}]}}

[Appium] Merged W3C capabilities {“desiredCapabilities”:{“app”:"/Users/sivasanka… into desiredCapabilities object {“app”:"/Users/sivasankaramalan/Documents/Katal…

[Appium] Creating new XCUITestDriver (v2.64.0) session

[Appium] Capabilities:

[Appium] app: /Users/sivasankaramalan/Documents/Katalon Builds/iOS/R3/REALTrans.ipa

[Appium] automationName: XCUITest

[Appium] deviceName: iPhone 8 Plus

[Appium] fullReset: false

[Appium] newCommandTimeout: 1800

[Appium] noReset: true

[Appium] platformName: ios

[Appium] realDeviceLogger: /Applications/Katalon Studio.app/Contents/Eclipse/configuration/resources/tools/deviceconsole/deviceconsole

[Appium] udid: 5B86B7C5-5AD8-4201-B604-60B260830AC9

[Appium] waitForAppScript: true;

[Appium] wdaLocalPort: 51533

[BaseDriver] Session created with session id: 3f85ffae-754d-4964-9e67-20c0c13fec8c

[iOSSim] Constructing iOS simulator for Xcode version 9.2 with udid ‘5B86B7C5-5AD8-4201-B604-60B260830AC9’

[XCUITest] Determining device to run tests on: udid: ‘5B86B7C5-5AD8-4201-B604-60B260830AC9’, real device: false

[XCUITest] No platformVersion specified. Using device version: ‘11.2’

[BaseDriver] Using local app ‘/Users/sivasankaramalan/Documents/Katalon Builds/iOS/R3/REALTrans.ipa’

[BaseDriver] Unzipping local app ‘/var/folders/yj/vlb491dx4yg78m4ps4_dw51r0000gp/T/2018215-40099-zmj9dk.lnhm/appium-app.zip’…

[BaseDriver] Unzipped local app to ‘/var/folders/yj/vlb491dx4yg78m4ps4_dw51r0000gp/T/2018215-40099-zmj9dk.lnhm/Payload/REALTrans.app’

[XCUITest] Continuing without capturing logs: iOS Simulator with udid 5B86B7C5-5AD8-4201-B604-60B260830AC9 is not running

[XCUITest] Setting up simulator

[iOSSim] Booting Simulator with UDID 5B86B7C5-5AD8-4201-B604-60B260830AC9…

[iOSSim] Simulator with UDID 5B86B7C5-5AD8-4201-B604-60B260830AC9 booted in 9 seconds

[XCUITest] Using WDA path: ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent’

[XCUITest] Using WDA agent: ‘/usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/WebDriverAgent.xcodeproj’

[XCUITest] Launching WebDriverAgent on the device

Screen Shot 2018-03-15 at 11.21.35 PM.png