Not able to record mobile for android mobile for an app

I am using android device RedmeNote3, i started record mobile and selected device and app. When i clicked start then its waiting for opening application and not moving forward, I waited so long. Below is the log:

[Appium] tmpDir: C:\Users\SSaxena\AppData\Local\Temp\\Katalon\Appium\Temp1519013708693

[Appium] Appium REST http interface listener started on 0.0.0.0:51888

[HTTP] → GET /wd/hub/status {}

[debug] [MJSONWP] Calling AppiumDriver.getStatus() with args: []

[debug] [MJSONWP] Responding to client with driver.getStatus() result: {“build”:{“version”:“1.7.2”,“revision”:null}}

[HTTP] ← GET /wd/hub/status 200 25 ms - 72

[HTTP] → GET /wd/hub/status {}

[debug] [MJSONWP] Calling AppiumDriver.getStatus() with args: []

[debug] [MJSONWP] Responding to client with driver.getStatus() result: {“build”:{“version”:“1.7.2”,“revision”:null}}

[HTTP] ← GET /wd/hub/status 200 15 ms - 72

[HTTP] → POST /wd/hub/session {“desiredCapabilities”:{“app”:“C:\\Integral_Projects\\Tools_Improvements\\Katalon_mobile\\MaterialLoginExample.apk”,“appWaitActivity”:“com.",“autoGrantPermissions”:true,“deviceId”:“577bf4dc”,“deviceName”:“Xiaomi Redmi Note 3 (Android 6.0.1)”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platform”:“ANDROID”,“platformName”:“Android”,“udid”:“577bf4dc”},“capabilities”:{“desiredCapabilities”:{“app”:“C:\\Integral_Projects\\Tools_Improvements\\Katalon_mobile\\MaterialLoginExample.apk”,“appWaitActivity”:"com.”,“autoGrantPermissions”:true,“deviceId”:“577bf4dc”,“deviceName”:“Xiaomi Redmi Note 3 (Android 6.0.1)”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platform”:“ANDROID”,“platformName”:“Android”,“udid”:“577bf4dc”},“firstMatch”:[{“platformName”:“android”}]}}

[debug] [MJSONWP] Calling AppiumDriver.createSession() with args: [{“app”:“C:\\Integral_Projects\\Tools_Improvements\\Katalon_mobile\\MaterialLoginExample.apk”,“appWaitActivity”:“com.",“autoGrantPermissions”:true,“deviceId”:“577bf4dc”,“deviceName”:“Xiaomi Redmi Note 3 (Android 6.0.1)”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platform”:“ANDROID”,“platformName”:“Android”,“udid”:“577bf4dc”},null,{“desiredCapabilities”:{“app”:“C:\\Integral_Projects\\Tools_Improvements\\Katalon_mobile\\MaterialLoginExample.apk”,“appWaitActivity”:"com.”,“autoGrantPermissions”:true,“deviceId”:“577bf4dc”,“deviceName”:“Xiaomi Redmi Note 3 (Android 6.0.1)”,“fullReset”:false,“newCommandTimeout”:1800,“noReset”:true,“platform”:“ANDROID”,“platformName”:“Android”,“udid”:“577bf4dc”},“firstMatch”:[{“platformName”:“android”}]}]

[debug] [BaseDriver] Event ‘newSessionRequested’ logged at 1519013720115 (14:15:20 GMT+1000 (E. Australia Standard Time))

[Appium] Merged W3C capabilities {“desiredCapabilities”:{“app”:"C:\\Integral_Pro… into desiredCapabilities object {“app”:"C:\\Integral_Projects\\Tools_Improvemen…

[Appium] Creating new AndroidDriver (v1.37.0) session

[Appium] Capabilities:

[Appium] app: C:\Integral_Projects\Tools_Improvements\Katalon_mobile\MaterialLoginExample.apk

[Appium] appWaitActivity: com.*

[Appium] autoGrantPermissions: true

[Appium] deviceId: 577bf4dc

[Appium] deviceName: Xiaomi Redmi Note 3 (Android 6.0.1)

[Appium] fullReset: false

[Appium] newCommandTimeout: 1800

[Appium] noReset: true

[Appium] platform: ANDROID

[Appium] platformName: android

[Appium] udid: 577bf4dc

[BaseDriver] The following capabilities were provided, but are not recognized by appium: deviceId, platform.

[BaseDriver] Session created with session id: 7718f8b1-f861-4470-aa67-33388e09c840

[debug] [AndroidDriver] Getting Java version

[AndroidDriver] Java version is: 1.8.0_102

[ADB] Checking whether adb is present

[ADB] Using adb.exe from C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe

[AndroidDriver] Retrieving device list

[debug] [ADB] Trying to find a connected android device

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[AndroidDriver] Using device: 577bf4dc

[ADB] Checking whether adb is present

[debug] [ADB] Setting device id to 577bf4dc

[BaseDriver] Using local app ‘C:\Integral_Projects\Tools_Improvements\Katalon_mobile\MaterialLoginExample.apk’

[debug] [AndroidDriver] Checking whether app is actually present

[AndroidDriver] Starting Android session

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“wait-for-device”]

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“shell”,“echo”,“ping”]

[AndroidDriver] setDeviceLanguageCountry requires language or country.

[AndroidDriver] Got language: ‘null’ and country: ‘null’

[debug] [Logcat] Starting logcat capture

[debug] [AndroidDriver] Pushing settings apk to device…

[debug] [ADB] Getting install status for io.appium.settings

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“shell”,“pm”,“list”,“packages”,“io.appium.settings”]

[debug] [ADB] App is not installed

[debug] [ADB] App ‘C:\Users\SSaxena\AppData\Roaming\npm\node_modules\appium\node_modules\io.appium.settings\app\build\outputs\apk\settings_apk-debug.apk’ not installed. Installing

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“install”,“C:\\Users\\SSaxena\\AppData\\Roaming\\npm\\node_modules\\appium\\node_modules\\io.appium.settings\\app\\build\\outputs\\apk\\settings_apk-debug.apk”]

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“shell”,“getprop”,“ro.build.version.sdk”]

[debug] [ADB] Current device property ‘ro.build.version.sdk’: 23

[debug] [ADB] Device API level: 23

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“shell”,“dumpsys”,“package”,“io.appium.settings”]

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“shell”,“ps”]

[debug] [ADB] Device API level: 23

[debug] [ADB] Getting connected devices…

[debug] [ADB] 1 device(s) connected

[debug] [ADB] Running ‘C:\Users\SSaxena\.katalon\tools\android_sdk\platform-tools\adb.exe’ with args: ["-P",5037,"-s",“577bf4dc”,“shell”,“am”,“start”,"-W","-n",“io.appium.settings/.Settings”,"-a",“android.intent.action.MAIN”,"-c",“android.intent.category.LAUNCHER”,"-f",“0x10200000”]

Cam anyone help what is the problem here.
Thank you
shruti

I am also getting same . Can anyone please help to resolve this.

I am not getting any error log even, no idea what is the problem.