Node.js not installed

hello
I try to make an automated test with my phone via Katalon.
I installed Node.js and Appium but when I click on Spy mobile or Record Mobile an error windows is shown " unable to start application on this device: Node.js is not installed".
I use wind 10 64bits and I’m sure 100% that the node.js is installed .
Please help me and thank you.

1 Like

Hello
I don’t know what happening but I turn off my laptop and I turn on
the problem is resolved !!!

Hey, I am also having the same issue, any idea why this is happening ??

Screen Shot 2018-05-10 at 3.39.52 PM.png

2 Likes

Having the same issue, installed node with nvm

It seems like nobody cares about helping us to solve simple issues with installation because we did not pay.

2 Likes

Same issue . Please response

Hi @alex.k,

Can you tell us how you installed node and what version you’re using? If you type node --version from the command line, what do you see?

Thanks,

Chris

I have installed NodeJS regular for windows and when i checked version in cmd is - v10.15.3

So i think it installed correctly

Hi alex,

Is appium installed?

Yes i installed appium . but it shows me

image

1 Like

Setting Up the Appium Directory

  1. Open Katalon Studio and Go to Window Menu in the toolbar.
  2. Select Katalon Studio Preferences > Katalon > Mobile
  3. Set Appium Directory to the installed folder. User can browse or can paste the path.

By default, it’s usually installed at C:\Users{user login account}\AppData\Roaming\npm\node_modules\appium.

Problem is the is do set in the preferences
but i think it didnt taking the exe it self when im pointing him to that directory where the Appium exe appears ( as i see it’s a exe but a shortcut - maybe the reason is that ? )

I even point to that exact - C:\Users\Alex\AppData\Local\Programs\Appium\Appium.exe

do you install appium desktop or server?
if you install appium desktop, use this phat “C:\Users(userdomain)\AppData\Local\Programs\Appium\resources\app\node_modules\appium”
and recommended appium server version 1.8

1 Like

I have installed this one . I dont know if it’s desktop or server - thinks it’s the same beacuse when u download desktop or server it’s the same file

1 Like

Oke, thats appium desktop.
just try to set appium directory with i mention before.

Im also getting this error. Tried to run a simple open browser step on an emulator. But its throwing error “It appears that you dont have NodeJS…”

But i have already installed both Appium and NodeJS
image

And I also have set the path in settings

Any ideas?

Update : Finally I was able to open browser and launch google on an emulator :joy:

1 Like

Im also facing the same error. How did you resolve this issue?

reboot get resolved

Im also facing the same error. How did you resolve this issue? I have installed using nvm.