No mobile device with name 192.168.233.101:5555 available (katalon+jenkins+genymotion)

Command console:
katalon -noSplash -runMode=console -projectPath=“C:\Katalon_Studio_Windows_64-5.4.1\projects\xxx\xxx.prj” -retry=0 -testSuitePath=“Test Suites/Regression test suite” -executionProfile=“default” -deviceId=“192.168.233.101:5555” -browserType=“Android”

1. Create command with Genymotion device
2. Send this command to jenkins
actual: No mobile device with name 192.168.233.101:5555 available

pls help if someone know solution

How can you get that deviceId value?

Vinh Nguyen said:

How can you get that deviceId value?

from command generation in katalon

So is the device up and running when you execute it? You need to make sure this device is up and running from Genymotion side

Vinh Nguyen said:

So is the device up and running when you execute it?

yes
1. I opened and running device
2. Generate console commant in katalon (without running device you can’t create console android command)
3. Enter command to jenkins and start job

@Vinh Nguyen do you have solution?

guys any ideas?

1 Like

Same issue for me when I run command from Jenkins. Command example:

katalon -noSplash -runMode=console -projectPath="D:\Program Files\Jenkins\workspace\RunTests2\ProjectNae.prj" -retry=0 -testSuitePath="Test Suites/MyTests" -executionProfile="local" -deviceId="08af5b931831bba0" -browserType="Android" 

If to run the same command in cmd it will work.

oleg,
This might be issue with Jenkins running as service. Because it creates some system user and may not know anything about devices connected to machine, don’t know why this.
Workaround is to start jenkins not as a service but from command line. In this case jenkins will be started by your user and finally can find a device

1 Like

Hi Same problem here,
The log:

Delete folder: bin
Delete folder: Libs
Opening project file: D:\Testmob\Testmob.prj
Parsing custom keywords in Plugins folder…
Generating global variables…
Parsing custom keywords…
Project ‘Testmob’ opened
18:39:23.475 [main] DEBUG com.kms.katalon.core.testdata.TestDataFactory - Finding test data with id ‘Data Files/GralVal’
18:39:23.534 [main] DEBUG com.kms.katalon.core.testdata.TestDataFactory - Test data is excel file, reading excel file
18:39:23.535 [main] DEBUG com.kms.katalon.core.testdata.TestDataFactory - Reading excel file with source file ‘D:\Testmob\MobSpreadsheet.xlsx’ and sheet name ‘Sheet1’
com.kms.katalon.execution.exception.ExecutionException: com.kms.katalon.execution.exception.ExecutionException: No mobile device with name ‘Pixel_2_API_28’ available
at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.getConsoleLauncher(TestSuiteLauncherOptionParser.java:167)
at com.kms.katalon.execution.console.ConsoleExecutor.execute(ConsoleExecutor.java:77)
at com.kms.katalon.execution.console.ConsoleMain.launch(ConsoleMain.java:151)
at com.kms.katalon.console.application.Application.runConsole(Application.java:76)
at com.kms.katalon.core.application.Application.runConsole(Application.java:87)
at com.kms.katalon.core.application.Application.start(Application.java:70)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: com.kms.katalon.execution.exception.ExecutionException: No mobile device with name ‘Pixel_2_API_28’ available
at com.kms.katalon.execution.mobile.configuration.contributor.MobileRunConfigurationContributor.getRunConfiguration(MobileRunConfigurationContributor.java:63)
at com.kms.katalon.execution.mobile.configuration.contributor.AndroidRunConfigurationContributor.getRunConfiguration(AndroidRunConfigurationContributor.java:29)
at com.kms.katalon.execution.collector.RunConfigurationCollector.getRunConfiguration(RunConfigurationCollector.java:103)
at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.createRunConfiguration(TestSuiteLauncherOptionParser.java:231)
at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.buildRunConfig(TestSuiteLauncherOptionParser.java:197)
at com.kms.katalon.execution.console.entity.TestSuiteLauncherOptionParser.getConsoleLauncher(TestSuiteLauncherOptionParser.java:164)
… 17 more

C:\Program Files (x86)\Jenkins\workspace\MobGeneral>exit 2
Build step ‘Execute Windows batch command’ marked build as failure
Finished: FAILURE

My First Tc of the suite
image

Without Jenkins, runs perfectly.

Did someone manage to fix it ? Help please.

Hello, i still the same try to use this code. do you have any solution ?

I am also having the same issue.
Any solution?

Any idea about this, getting at Jenkins running as windows service.
Caused by: com.kms.katalon.execution.exception.ExecutionException: No mobile device with name ‘c8eba169’ available