New methods in external library / .jar not being recognized in Katalon

Hello there,
I’ve got issues getting my newly exported .jar file to work, so that it recognizes the new methods.

I’ve so far:

  • externally check the jar for the new methods being integrated (methods inside)
  • send the .jar to a colleague to test it (integration works as expected, methods found in Katalon)
  • last methods I integrated into jar seem to work
  • Used different version of Katalon to include .jar

The .jar has been:

  • removed / included manually into Drivers folder (several times)
  • removed / Included via Katalon GUI (several times)

Any ideas what I could do else?
Why is it working at my colleagues? (and not on my machine?)

What version of Katalon?

Have you tried cleaning the project? File > Clean up

Have you tried with a new project? Does it work then?

Cleanup with jar included => nothing happens

  1. Close Katalon, remove jar. Clean up
  2. Start Katalon, Include jar ==> works

Thank you!

1 Like