1 - I sincerely hope the following APIs are fixed/improved and then the improved documentation is added as I suggested:
3 - For all APIs, ensure the phrase “TestObject” is used where sometimes “web element” has been used. The current documentation conflates and confuses the two terms when in fact they are entirely separate entities. If they were not separate, we wouldn’t need the following:
WebElement elem = WebUiCommonHelper.findWebElement(to, …)
to convert between them.
Example: in the Description it says “web element” whereas it should say “TestObject”.
[Web UI] Verify Element Not Checked
Estimated reading time:
Verify if the given web element TestObject is NOT checked.
||Represent a web element.
||System will wait at most timeout (seconds) to return a result.
||Specify failure handling schema to determine whether the execution should be allowed to continue or stop.