KRE hangs on Linux

Hi,
We have been running KRE for a while 100s of unit tests in a Suite, and everything is working well until we decided to create a dedicated server to run KRE, that’s when things started to break.
The tests run faster on the dedicated ubuntu environment (roughly 20% faster), but then it just hangs after executing 50 tests, and then it starts to crawl (roughly 2 minutes delay in each test)
See this log

23:03:34.886 DEBUG TC TB Poll 004 - Empty Poll choice alert - 1: openBrowser("")
23:03:34.890 INFO c.k.k.core.webui.driver.DriverFactory - Starting ‘Chrome (headless)’ driver
11:03:34 PM org.openqa.selenium.remote.DesiredCapabilities chrome
INFO: Using new ChromeOptions() is preferred to DesiredCapabilities.chrome()
23:03:34.891 INFO c.k.k.c.w.util.WebDriverPropertyUtil - User set preference: [‘args’, ‘[window-size=2000,2000]’]
23:03:34.892 INFO c.k.k.core.webui.driver.DriverFactory - Action delay is set to 0 milliseconds
Starting ChromeDriver 96.0.4664.45 (76e4c1bb2ab4671b8beba3444e61c0f17584b2fc-refs/branch-heads/4664@{#947}) on port 18957
Only local connections are allowed.
Please see ChromeDriver - WebDriver for Chrome - Security Considerations for suggestions on keeping ChromeDriver safe.
ChromeDriver was started successfully.
11:03:35 PM org.openqa.selenium.remote.ProtocolHandshake createSession
INFO: Detected dialect: W3C
----- Delay is here --------
23:05:45.155 INFO c.k.k.core.webui.driver.DriverFactory - sessionId = 944322209d457041089ead17f7087605
23:05:45.172 INFO c.k.k.core.webui.driver.DriverFactory - browser = Chrome 96.0.4664.93
23:05:45.172 INFO c.k.k.core.webui.driver.DriverFactory - platform = Linux
23:05:45.173 INFO c.k.k.core.webui.driver.DriverFactory - seleniumVersion = 3.141.59

The issue is not CPU or RAM limited, we tried different scales doubling each, we also tried different cloud providers, and it was all the same. When we tried a Windows server, the problem wasn’t there (although it was slower than Ubuntu in executing the first 50 tests), so the problem appears to be related to the Linux version of KRE (Katalon Version: 8.0.5)

Any help in how we can resolve this issue is appreciated.