Katalon Studio Executes Only Partial Test Cases

I have a question. I’m trying to execute my test case using a lot of data in one time run (I aim to run automatic testing outside my working hours). I have prepared 100 data in my Excel data files (I marked when the case has been executed). When I execute the test case and check the results, Katalon only runs as many as 60 cases (this number varies each time the execution process, where it never covers the entire 100 data cases I have prepared), but in the log, Katalon is already marked as done (already in green).

What is the cause? Why can Katalon state done while not all cases have been executed? Are there settings or other causes that may be the reason for this? Additionally, I am using Katalon version 8.5.5

Can you provide a log or other more information to investigate the issue

I can’t reproduce it :frowning:

The information I can provide is:

  • I’m using Katalon 8.5.5.- I run 100 test cases, but only some are executed when Katalon is marked as done.
  • The time frame until the incident occurs is around 2.5 to 3 hours (not always happening, but quite often).- I’m using test data through Excel.
  • I run it through test cases, not test suites

So how do you launch 100 test cases if you do not use a Test Suite? Do you use TestOps to launch the TCs?

I am using a loop inside my test case for the number of data columns I have prepared in Excel.

It’s probably some timing issue… Without seeing your actual code, all we can do is speculate

Have you given up on this issue?

Hello. I want to say that this case is problematic and we (me and Willis) are not giving up on this.
We just doesnt have the prove screenshot, and now i have it.

As you can see on the picture, the status is done. It means that its not ‘Success’ Or ‘Failed’ as usual, but done.

This is the picture of Log Viewer. Its stopped on the last else if (i ==8) and its not running anymore.
I start from 08:50:39 and its done on 09:11:34 (I have code for calculate elapsed time, but its done, cant reach that).

I am using 9.0.0 Katalon Studio.
It happened quite rare so is there any information that you need ? Thanks.

Could you copy and paste your Test Script here?

Sorry, its credential. But i can tell the big picture of the scripts here.
I run 1 test case (lets say MAIN)
MAIN is calling Document Monitoring (on the picture)
on the picture itself, i wanna check all the values from filter data (click search, and get row size and column size, use 2 loop, and its checking every column on every row)
it got stucked on checking if the column is on 8.

If you can’t share your code on here, or any part of it, because it’s confidential, then we can’t help you…

This looks a little complicated, from the screenshot… I would suggest taking advantage of guard clause technique, functions, classes, and deciding whether or not you really need that if-else, inside that nested for-loop, inside that nested-if…

DM me and I can help you refactor it. The issue might automatically fix itself afterwards