Katalon running on Java 10


I have developped a whole library that I use via Katalon but one of the main features only works in Java 10 (due to an old bug in Java, see https://bugs.openjdk.java.net/browse/JDK-8196030 for more info).
Basically, the Robot class does not move the cursor to the right position.

This bug is from the Win 10 creators update but it is the same kind as the one that appeared with windows 8 and server 2012 a few years ago.

So my problem is: I have to develop my library using jdk 10 while Katalon does not support it (no way to add a jdk superior to the one used by eclipse/katalon).

This is completely blocking my testing on some of our oldest servers and i do not have a good solution for it.

My question is therefor: When is Katalon planned for Java 10 support, if it is at all?

If you have an alternative and/or a quick fix, I would greatly hear/read it.




Hi @Bertrand Besnard,

Thank you for choosing Katalon Studio. Here try this
- Navigate to Katalon > Preferences
- Search for JRE in the search box
- Add the path to the JDK 10 folder
Note: Please be aware this may cause issues with the Katalon IDE.




I have tried this but since Katalon is not using the most recent build of Eclipse, jdk 10 is not supported. All I get is an error when I try to add the new jdk (older ones work just fine).

If any of you were to encounter the same issue, here is a quick fix that seems to work on all concerned Windows OS:
Find your JDK folder, right click on java.exe, disable DPI scaling (remember to do this for all concerned users) and then do the same for javaw.exe.

This worked for me after downgrading my code to Java 8 compatibility.

I no longer have the bug but I guess, adding support for Java 10 is still a good idea.