7.8.2 Katalon Studio and Oracle 15.x.x JDK / JRE

I created some Java Code in STS (Eclipse) and created a jar of the code that I then added to the Drivers folder in Katalon. I then created a groovy use case that referenced that code. When I executed my test script I got:

Test Cases/lib/db/recreate_db FAILED.


  com/js/enigma/enigmakatalondb/helper/shell/ShellHelperImpl has been 
  compiled by a more recent version of the Java Runtime (class file version 58.0), 
  this version of the Java Runtime only recognizes class file versions up to 52.0

I then tried to update the installed JRE but when I navigate to my JAVA_HOME:


the katalon error is:

 Target is not a JDK root. System library was not found.

My question is:

Why does Katalon not support jdk 15.x.x when STS (Eclipse) does?

Both Katalon and STS are built on Eclipse yet Katalon cannot support the same versions of java. Why?

I saw older questions (from roughly 1 to 2 years ago) where Katalon could not support jdk 1.11 - why is nothing being done to support up to date jdks? The system changed in jdk 1.9 which is ages ago. I think a priority ticket should be raised to provide compatibility with up to date JDK / JREs. What does Katalon think about this?

Thank you for your time in reading this question. Thank you for Katalon.

Note that homebrew (a package manager) on the mac does not even have the option to install these very old versions of the JDK. They are considered too old to be supported.

I solved the issue by setting compliance source and target to 1.8 in the pom file of the jar I built in STS (Eclipse) to drop into the Drivers directory of Katalon. Now Katalon is executing the code despite the JDK of Katalon being ancient :slight_smile:

UTF-8 UTF-8 1.15 1.8 1.8

@john.charles.dickers good to know katalon is still usable despite apple paranoia :smiley:

ha ha - apple paranoia - even bank accounts are paranoid when it comes to Apple products.

Lucky me, i don’t have to use apple stuff.
Linux all the way :slight_smile: