Katalon Recorder 5.8.4 waitForElementPresent generates [error] [object Object] -> same issue in 5.9.0

Since Katalon 5.8.4 update I get “[error] [object Object]” log messages with the “waitForElementPresent” command.

I managed to get some code running by replacing this by “pause” with time values, but it is very inconvenient, take way more time to execute.
I have many “waitForElementPresent” in my test cases.

ERROR:

[info] Executing: | clickAndWait | id=submit | |

[info] Executing: | waitForElementPresent | //a[contains(@href, ‘/auction/list’)] | |

[error] [object Object]

[info] Pausing

[info] Stop executing

image

image

I usually use the target values like “id=auctionMenu-link” and for this one I also tried with “//a[contains(@href, ‘/auction/list’)]” as well.
But it does not work.

I reinstalled Katalon Extension
Using Chrome Version 102.0.5005.115 (Official Build) (64-bit)

Any hints?

HTML CODE:

<li class="group-end">
                <a href="/auction/list" id="auctionMenu-link">
                    Auction/Reserve Sale
                </a>
            </li>
1 Like

Hi @Michel_Blais63, thank you for sharing this with us. Our internal team will check and let you know soon. Happy testing!

I have extra information that may help find the issue.

When an error occurs, the popup window asking to Continue appears and sometimes, I say sometimes, when I click continue the code continue and looping through a CSV File, the code come back to the line that previously failed and execute the line with “waitForElementPresent”.
But it sometimes stop at another line where i have another “waitForElementPresent”, I click continue after the popup window appear and sometimes it just stays there, never times out unless I do something in the page, like click another link.
At one point it cannot finding a simple link as if it’s looking for something that is not there yet.
The Continue button does not always work, even though the page component is there.
This code worked for months, cannot wait to have a solution for this issue.

UPDATE:
i just noticed that all my “waitForElementPresent” are after “clickAndWait” commands.
Looks like this is the cause, I added pause between the “clickAndWait” and the “waitForElementPresent” and the code runs.

Still, this is not efficient, i didn’t have to add pauses before. Code take much longer to run now, half a second is not enough so I use 1 second. Take now 15 minutes more to run the code. But at least it works.
I will have to add pauses in every code that were working fine before.

Thx.

Hi,
Update, The 5.9.0 update did not address my issues.

Still having [error] [object Object] errors after the “clickAndWait” command followed by “waitForElementPresent” command. Error occurs on the “waitForElementPresent”.

I still need to add a “pause” between these two commands to make the code work.

Thank you for any solutions on this matter.

By the way, thank you for allowing the use of the “tab” key to navigate between cells and rows.
I have been missing this functionality for a long time.

1 Like

Hi Michel, thank you for following up and sorry for the late reply. I’m checking again today and let you know asap. Good day to you :+1:.

Hi,
Definitely, the “clickAndWait” or the “waitForElementPresent” does not wait “long enough”.

What is it waiting for, the 200 OK response or for the page to load completely?

As stated earlier, I need to add the “pause” command before each “waitForElementPresent” command.

Thank You for the help.