Issue with WebUI.verifyElementPresent in Katalon 5.4

When I call the verifyElementPresent in an object that does not exists, after the timeout period I received the following message:

[INFO] - Found web element with id: ‘Object Repository/Profile/Verification/span_Successfully Submitted’ using heuristic method. Maching attributes: [tag].

This is a serious issue because actually the function verifies the

of an object which does not exists. 

Hi George,

We will double check and quick fix it within this week.



This issue has been super quick fix. I’ve double checked it and above implementation has been reverted. We’ve applied some methods to locate an element further but looks like there is an issue with it due to lack of testing. We will test this and release it in the later release.

In the meanwhile, while waiting for our updater to update this version, you can re-download Katalon Studio on our website. I’m very sorry for this inconvenience.


Thank you very much for your answers guys! Have a nice day.

Hi @“Vinh Nguyen”
Is this above issue fixed? because I still got the same issue in the latest version 5.6

Katalon Studio heuristic method issue.png

Hi @Vinh Nguyen ,
Even I am facing the same issue with the latest version 5.6.0. Not sure if this is fixed.

Hi @Vinh Nguyen
Is this above issue fixed? because I still got the same issue in the latest version 5.6 in my web. please fixed it

Hi ,
I am facing the same issue as well ,is there any workaround for it ?

On 5.6, the result still marked as failed. It just logs these lines and will not affect the current behavior of this keyword

See my try below:
1. Object’s properties:

2. Execution:

Screen Shot 2018-08-21 at 16.26.39.png

Screenshot at Aug 21 16-28-51.png

In my case its not working as expected, trying on 5.6 :


Also not working for me. Additional problem is that the defined timeout of my if else doesn’t take any effect and so I have to wait for the global timeout.


Having this message in 5.6.3. “Web element found by heuristic method is not used because we can’t guarantee it reflects the intended element.”


I am having the same problem too.

1 Like

This message already reported by Youssouf ([…]can´t guarantee it reflects the intended element.) does occur on Chrome/FF headless mode as well although the tests working when using normal Chrome, literally making headless mode impossible to use.
Tried to select menu items via Basic, CSS and XPath without any change of the result.

Sometimes, when waiting for an element inside of an iframe to be clickable (after switching to the iframe) I get:

[INFO]   - Web element found by trial and error method is not used because we can't guarantee it reflects the intended element.

It is intermittent.
This is after updating to 5.7.0.

**It is happening with objects other than those inside of an iframe, too.

In my case I use a “If”-clause to close two initial pop-up screens which can be there but mustn´t. I use the timeout to get through this fastly (set to 2 seconds). When both pop-ups are active it works flawless but it needs always 10 seconds when only one of the pop-ups is missing and if both missing it needs 8s for the first and 5s for the second one.
Global time-out is set to 8 seconds and it seems to not have an impact on these times (when set to 20 it still stays the same).
So, although it is not an serious issue (in my case) its extremely annoying as it adds 13 seconds to each of the testcases.

I noted that timeout is checked twice but be unsure if it is related to this issue.

Is it intended that if the object isn´t found Katalon uses first heuristic methods and afterwards trial and error to find the object anyways?
If so, it works but it does make the waitForElementClickable method useless for If-Else clauses.


Many of our test cases are being effected with this incorrect behavior. From 3 releases its not being fixed. Hope it gets fixed at least in the next release 5.8 !!!


@Katalon Studio

Any update on this issue?



I’m also facing the same issue and I have to handle all the objects in Iframe. This issue seems to be a road blocker for me to continue further scripting, Could anyone suggest if there is any other workaround to identify the Iframe objects.