Katalon - Modify object then click new object

Hi All,

I’ve tried this multiple times with no success.

I have an xpath locator of: (//div[contains(@id, ‘knowledgelistviewlist’)]//td)[1] which is stored in an object called ‘Test Object’.

I essentially wanted to click it, then modify it and change [1] to [2] and click the next in the list. The problem is that it never seems to click the new element and says it’s passed. I’ve tried modifying the original object or even creating a new object but everything fails.

The last thing I tried was to create a new object all together and click it:

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject
import com.kms.katalon.core.checkpoint.Checkpoint as Checkpoint
import com.kms.katalon.core.checkpoint.CheckpointFactory as CheckpointFactory
import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as MobileBuiltInKeywords
import com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords as Mobile
import com.kms.katalon.core.model.FailureHandling as FailureHandling
import com.kms.katalon.core.testcase.TestCase as TestCase
import com.kms.katalon.core.testcase.TestCaseFactory as TestCaseFactory
import com.kms.katalon.core.testdata.TestData as TestData
import com.kms.katalon.core.testdata.TestDataFactory as TestDataFactory
import com.kms.katalon.core.testobject.ObjectRepository as ObjectRepository
import com.kms.katalon.core.testobject.TestObject as TestObject
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WSBuiltInKeywords
import com.kms.katalon.core.webservice.keyword.WSBuiltInKeywords as WS
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUiBuiltInKeywords
import com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords as WebUI
import internal.GlobalVariable as GlobalVariable
import com.kms.katalon.core.testobject.TestObject
import com.kms.katalon.core.testobject.ConditionType

TestObject newObject = new TestObject(“New Object”)
newObject.addProperty(“xpath”, ConditionType.EQUALS, “(//div[contains(@id, ‘knowledgelistviewlist’)]//td)[3]”)


It always says ‘passed’ but it never actually clicks the new object.

I also tried to modify the original after the first click, but that seems to just click the original one. Any ideas?

what is the Katalon version you are using?
we have some debates about some recent changes…

Strange, indeed.


Did you try creating ANOTHER new object that has nothing to do with the original two problematic objects? In other words, is dynamic TO creation and clicking working at all?

Using Studio Enterprise 8.5.5.
I haven’t tried that @Russ_Thomas - not exactly sure how to do that, but I can google haha

Sorry guys, I think i’ve realised I made a mistake in my xpath selector. There seems to be a another table within the table so it’s actually selecting the same element!!!