Katalon javascript calls don't work if Jenkins runs as a service


I have a Jenkins master slave architecture where Katalon runs in the slave If in the same computer, I run the script with Katalon, it works If I run it through Jenkins, it doesn’t work I have now to execute the Jenkins slave as a java web start instead of a windows service.
Could you fix the windows service issue?

This bug is detailed in this post:

Thanks in advance

The Windows server is running with a different account than the Jenkins one, but I don’t understand how can this impact the service, and not the Java Web Start This problem happened with some other third parties after Jenkins changed some security settings and they solved the issues. It is only the javascript calls that don’t work

And IE only, right?

IE is a hodge-podge of MS BS some of which is part of the OS. And that speaks to the issue you’re seeing where other browsers don’t suffer. Other browsers are not made up of OS-resident components (DLLs).

Were IE not so riddled with OS nonsense, MS would have deprecated it long ago (like Edge becoming a thin skin over chromium).

I could be wrong about all this - but really, this stinks of permissions/accounts/security issues.

And personally, I wouldn’t execute a browser or a test suite directly on a server – especially IE, it’s the worst. Servers are not (out of the box) configured to run desktop apps efficiently. But that’s just me. :confused:

Good luck and do let us know if Jenkins support provide a fix.


There is an open bug in Jenkins:



This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.