Katalon does not update the REST request variables when called the request again. It still shows the old parameters list

I am using the “New Draft REST request” and testing the request. For the first time, Katalon took the values which I have requested. Later I changed the values and hit the request.
Updated values are not going in the request.
The first-time request entered page number as '2’
Later I am requesting page number as '3’

There is a similar post in the community but did not have any solution

@huynguyen/@duyluong please help

Hi @sudheer.dj,
What version of Katalon Studio do you use?

It’s latest 7.6.6

Hi @sudheer.dj,
We have reproduced the issue and will fix this in upcoming releases.

Thanks @huynguyen.
Could you please tell in which release this can be released.
Is it possible to say what was the issue?

Hi All,

This issue has been fixed in version 8.0.5. Please check out our Release note for more information.

Shin

Following on from my previous comment:
The issue in my previous comment does not get resolved if I close the test case and reopen it.

The issue DID get resolved when I changed the Test Object in the Manual view to a different test object, saved, changed it back to the previous value, saved and then executed.

However, the above did not work when I changed the value of PortNumber back to an invalid value (it continued to use the correct value).

I also could not get the behavior in my previous post to replicate when I deleted the test case and recreated it - I could not get it to fail with an initial invalid value (looks like it was using the values of the variables in the Test Object and ignoring the values in the test case).

I then recreated the test case, created variables assigning value of PortNumber to 55026, added a Send Request and Verify step associated with the test object, changed the parameters in the Script view to use $Host and $PortNumber. Test case failed with a groovy error. Following screen shot shows the call and the error:

Finally, I also tried sending variable values as ${Host} and ${PortNumber} - got the following error:

I am out of ideas at this point - so I would appreciate any help to get this to work.

It looks like this issue (or something very closely similar) is still occurring in TestStudio Enterprise v8.2.5 (Trial version).

I have a Test Object for a Web Service Request with a Parameterized connection string. Note: The Test Object also has some verification code - but this is not relevant to the issue I am reporting - the problem is with the initial GET request.


When I ran Send Request and Verify in the Test Object itself, it passed (as expected).

I created a Test Case which calls Send Request and Verify on this Test Object and has a Host and PortNumber of its own.
image

Initially, I set the value of PortNumber to a value different than the default value in the TestObject (55026). The Test Case failed at the Send Request step - which is as expected (port number is incorrect).

I then changed the value of PortNumber in the TestCase to match the value in the TestObject (55004 which is the correct value).
image

I expected the Test Case to pass - however it failed. Error message at the Send Request step shows it is still using the previous (incorrect) value of 55026).

The Script tab of the test case shows that it is still sending the initial value - it did not get updated when I changed the Variable value.

I am new to Katalon - so please forgive me if I missed any steps and share what I need to do to correct.
.

Still looking for ideas to resolve the issue reported in my last 2 posts.
Please note that the order of the posts somehow got swapped during the approval process - so please read the second post first - then the first post.

Any help would be much appreciated.