Katalon crashing post updating to Macos 13.0 Ventura

Katalon studio is crashing post upgrading to latest mac os.
Katalon_Crash_Logs (226.4 KB)


Hi @hariprasad.yerubothu, thank you for letting us know about this issue.

I’ll go ahead and move your topic to the Bug Report category so that our team can better support you. Thanks!


Hello Katalon Community,

yesterday I installed the new MacOS Ventura on my Macbook. After the installation i wanted to work with Katalon Studio, but everytime i start the Application it gets to the Point where its loading the Projekt and then crashes.

I tried to reinstall the Application.

Im normaly using the Katalon Studio Standalone Edition, but in this Case I also tried the Plattform edition to see if it works. It hast the same Issue.

Has anyone noticed the same? And is there an Update planned to fix this Issue?

Best Regard

Hi chị Jass, could you take a look at this issue? Is the new OS update causing any glitch with KS? Thanks chị

Team, any update on this issue.

here is my error log file
katalon error log.rtf (226.5 KB)

I am facing the same issue after updating MacOS. Any update?

Any update ? For thus issue

how long does it usualy take to fix this issue?

i think this happens in every major update in OS

It’s also happening to my team. We’re using the latest Platform Edition.

For completeness here is my crash report:
KatalonCrashVentura.txt (203.0 KB)

Same issue for me, any news yet?

Facing similar issue any workaround suggested?

Same here. I am facing the same issue after updating MacOS Ventura.

Hi everyone

We are working on the fix and we’ll keep you posted once there’s a new release.

Thank you for your patience,


I am also facing the same issue please could you provide the solution at the earliest.

Is there any update? This is urgent!

i have the same problem, any solution for this ?

Hi there,

Has anyone faced the issue with macbook/iMac M1/M2 chip?

I face it after my work Macbook Pro 13" (intel) upgraded to Ventura.
My suspicion is that it has to do with the device ID and how it is generated and used for license check. I did try to reinstall after removing the App and the ~/.katalon folder. But it fails as well. UI shows OK for like 20 seconds and the UI disappears.
I will try on my private M1 Macbook Pro